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OneStream XF Version 4.5.0  
Release Notes 

OneStream XF version 4.5.0 is a minor release with a minimal amount of enhancements and resolutions 
to reported issues. This includes support for SAML 2.0 Single Sign-On (SSO) authentication for user 
authentication and an enhancement for Extensible Documents for working with Microsoft Office Update 
Version 1804 or higher. These Release Notes list the changes in OneStream XF, other changes in XF 
MarketPlace solutions during this timeframe and includes an Upgrade Guide.  

Release Date: October 24, 2018 
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Important Notes 

Prerequisites 

See section of this document entitled OneStream XF 4.5.0 Upgrade Guide for important notices and 
details regarding planning your upgrade. Also refer to OneStream XF version 4.4.1 Release Notes if 
upgrading from a previous release.  

Compatibility 

See the OneStream XF 4.5.0 Upgrade Guide later in this document for information on compatibility of 
the OneStream Studio and OneStream Excel Add-in versions.  

OneStream XF 

New 

Security 

• Added external authentication support for the SAML 2.0 SSO authentication protocol. See 
OneStream XF Installation and Configuration Guide for details and an example of configuration 
for Active Directory Federation Services (ADFS). (8446) 

Presentation 

• Improved the Excel Add-In’s Refresh Worksheet and Refresh Workbook performance by adding 
the “Use Minimal Calculation for Refresh” option in Preferences. When set to True (the new 
default setting), this option will only collect data for the XF cells that are on the selected 
worksheet or workbook. (9107) 
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• Enhancement to Excel Add-In was added to account for a known Excel situation when running 
on certain touchscreen hardware. If the “Refresh Sheet” or “Refresh Workbook” is pressed but 
the cells containing XF functions do not complete their calculations when processed, change the 
“Disable Interactive User During Refresh” setting under “Preferences” to True. (2656) 

• Enhanced Excel Add-In feature of Save Offline Copy by adding an option in the Preferences to 
Retain All Formatting when Saving Offline. For better performance, set this to False. (8600) 

Changed 

Presentation 

• Enhanced Extensible Documents that are authored (in Microsoft Word, and Microsoft 
PowerPoint) to support recent Microsoft Office updates (versions 1804 or higher).  The Alt Text 
Description field for Picture controls will be used instead of the combination of Alt Text Title and 
Description in previous versions. Pre-existing Extensible Documents will still run if the XF 
required settings are in the Alt Text Title field and the XF optional settings are in the Alt Text 
Description field (per the original design). (8881) 

 

Workflow 

• Improved performance when saving and submitting data in a Workflow with thousands of 
Workflow Profiles. (9039) 

Known Issues 
• Report Preview Error in Cube View Sharing Rows/Columns with same Name in Shared Cube 

Views. (2651) 

• When exporting or sending an image via an email from Spreadsheet or Text Editor, the options 
for Subject Field or Page Border Field are cut off in the Export Document dialog box.  (5394, 
5395, 5396, 5397) 

• When opening a Workbook that contains OneStream Formulas/Cube Views/Quick Views directly 
from the file system before opening a blank Excel workbook and logging into the OneStream 
Excel Add-In, the user may receive a “Cannot run the macro ‘XFInternalSetConnectionInfo’ error. 
As a workaround, the user can open Excel, log in and then open the XLSX file, or they can launch 
the file from within OneStream if it is in the File Repository. (5024) 

• Error message received in very specific situation when closing Print Preview in Spreadsheet and 
Text Editor after the user had previously selected Page Layout/Two Pages, and then selected 
Show Cover Page. (5738) 

• In order to have SSL security configured between the OneStream Application and Web Servers, 
Application Pools must use a local administrator account rather than a domain account. (4603) 

• In Spreadsheet, when editing a formula using the Function Arguments dialog, a reference to a 
Named Range that exists on a different tab will result in an error. As a workaround, edit the 
formula in the Formula Bar or only use the Function Arguments dialog to reference Named 
Ranges that exist on the same sheet. Planned for next major release. (5834) 

• When printing in the Spreadsheet Feature and selecting the Page Range option of Current, all 
pages are printed, not just the current page. (5877) 

• Business Rule which contains a ~ with passed parameters will only run when the user running it 
has a Culture Code set to English. Workaround is to use a different parameter separator other 
than ~ in rules for time being. Planned for next major release. (5958) 

• Rendering of a Dashboard that contains a Map Component results in an error only when using 
OneStream App for Windows. This error is not experienced with Map Components when using 
the browser version of OneStream XF. Planned for next major release. (5974) 
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• An apostrophe in the Name of a Confirmation Rule results in an error when re-loading into a 
OneStream XF Application after extract. As a workaround, refrain from using an apostrophe in 
Confirmation Rule names for the time being. (5975) 

• When a cube view uses CVC/CVR, CVR seems to be "not valid" when one of the rows included in 
the CVR formula are suppressed. As a workaround use the method of using direct member 
lookups (for the rows that are using Math where there is suppression) and then doing math. 
(5943) 

• SAML 2.0 does not initiate an authentication flow with a username and password from the 
service provider therefore Client API authentication with SAML 2.0 is not supported. This may 
limit the automation capabilities available. (9158). 

Contacting Support 
OneStream Support can be contacted at any time by first registering at our support site at 
http://support.onestreamsoftware.com and then emailing support@onestreamsoftware.com.  To gain 
access to the XF MarketPlace, email OneStream Support. 

 

http://support.onestreamsoftware.com/
mailto:support@onestreamsoftware.com
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OneStream XF MarketPlace Updates 

The following updates were made to XF MarketPlace solutions since the OneStream XF 4.4.1 Release. 
Refer to the specific solution’s release notes in XF MarketPlace for more details on these improvements. 

New 

Process Control Manager (PCM) 

Process Control Manager (PCM) is a solution used to provide business users with an intuitive and easy to 
manage review and approval process of Workflow Submissions.   

The included OneStream XF Workflow functionality is quite powerful and will meet the design 
requirements for most XF Applications.  Process Control Manager expands upon this native functionality 
to allow additional granularity in process control and also adding the Cube, Origin dimension and 
detailed Workflow Channel control of Accounts, to provide focused process control in multifaceted 
workflow environments. 

This solution provides a framework for enhanced control of Workflow data submissions by managing:  

• Which Workflow users/security groups can input data or complete review steps 

• Which Scenarios/Periods can be modified 

• Which Origin dimension input channels can modify data 

• Which Accounts can be modified based on their related phase (aka Workflow Channel) 

Home Page Manager (HOM) 

The Home Page Manager (HOM) solution is an administrator utility for managing the default OneStream 
Home Page for individual users and user groups.   The solution allows the System Administrator to easily 
assign new users or manage current user access to default OneStream Home Page that is displayed at 
login to the application.  

Process Blocker Utility (PBL)  

The Process Blocker Utility (PBL) solution is used by administrators to temporarily prevent new Data 
Quality and Data Management processes from starting while the Process Blocker is activated.  This 
allows administrators to complete OneStream XF application maintenance efficiently in environments 
where it is difficult to schedule outages because of the number of concurrent users working in multiple 
time zones.  Attempts to start new Data Quality or Data Management process will be blocked and the 
users will receive a popup window with the application maintenance message.  Administrators can 
complete their maintenance once the active tasks have completed.  Normal processing will resume 
when the administrator unblocks the application after they complete their maintenance. 

Changed 
Account Reconciliations (RCM) 

Maintenance and user improvement features. Revised and additional reports as well as report filters. 
Ability to export and import Reconciliation Inventory Items to Excel. Simple navigation of document 
attachment history. Over a dozen other enhancements. 
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Security Audit Reports (SAR) 

This is a minor update to version SAR PV430 SV100 with updates to Business Rules to provide continued 
improvements to audit reporting. Related reports from Standard System Reports have been moved to 
this solution for simpler and central delivery.  

Help Desk (HDK) 

The theme of this PV440 SV100 release is incremental improvements including Email notification to 
ticket creator when ticket is closed, clearing closed date information when Closed ticket is Opened or 
Assigned, added slider to Ticket Editor—Update screen to help show Save button and supporting 
documents now open in associated viewing application when Download is selected. 
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OneStream XF 4.5.0 Upgrade Guide 

This document provides an overview of OneStream XF’s upgrade process when moving from an earlier 
OneStream XF release to 4.5.0. The anticipated audience for the upgrade process is Information 
Technology professionals responsible for installing, maintaining and supporting OneStream XF.    

Review the following OneStream XF 4.5.0 requirements prior to scheduling an upgrade and any related 
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.  

1.) If upgrading from OneStream XF version 4.1.x or earlier, OneStream updated to .NET 4.7 to stay 
current on the latest version of the .NET Framework, which is required for Microsoft’s security 
standards and for advanced features.  Please note, Microsoft provides the .NET Framework 4.7 
optional update through standard Microsoft Windows Updates.   

2.) The most recent database schema update was 4.2.0. There is no need for a database schema 
update if upgrading from 4.2.x or 4.3.x to version 4.4.1. If upgrading from a version before 4.2.0, 
Database Schema updates must be implemented as part of the upgrade on every Application and 
Framework database. Full Database Backups are required. 

3.) The 4.4.1 version of the OneStream Studio and OneStream Excel Add-in are not backward 
compatible with prior versions and must be updated. These either need to be uninstalled and 
reinstalled or use the Client Updater. See OneStream XF Installation and Configuration Guide for 
details under the section “Upgrade or Downgrade via OneStream.”  

4.) If upgrading from a version before 4.2.0, it is required that all OneStream Applications complete the 
Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade process.  

Scheduling the Upgrade 
It is recommended that this upgrade be performed by the OneStream Software Technical Support Team.  
Contact OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com. 

Pre-Installation Upgrade Checklist 
The checklist below details the items that should be completed prior to beginning the upgrade 
operation: 

Step 1: Perform a full backup of all OneStream databases. 

Step 2: App Pool Service Account must use an Administrator ID or be added to the Performance 
Monitors User Group and Performance Log Users Group.  

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace 

1.) Login to the OneStream XF MarketPlace and select Software Download in order to access the latest 
version of OneStream XF. 

2.) Download the Full Package or Server Software to acquire the appropriate setup files for the server 
installation. 

Step 4: Verify the Location of the OneStream XF Configuration Files 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 

mailto:support@onestreamsoftware.com
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Files\OneStream Software\OneStreamWebRoot\OneStreamWeb, on web servers, and choose the 
web.config file 

4.) The web.config will open and display the path to the corresponding configuration files: 
XFAppServerConfig.xml and XFWebServerConfig.xml 

5.) Take a copy of the config file 
6.) Copy and paste the configuration file path in a place that is easily accessible as this will need to be 

re-entered following the upgrade process 
7.) Close the file, and select No when prompted to save  
8.) Close the OneStream Server Configuration Utility 

Step 5: Verify the OneStream Service Account in Internet Information Services Manager (IIS) 

1.) Service Account must be an Admin ID or in the Performance Log User and Performance Monitor 
Users groups. 
This ID is necessary to use Queuing and CPU Monitoring. 

2.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

3.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and 
OneStreamWebAppPool are displayed in the Identity column.  Note this windows account and its 
password as this will need to be re-entered in IIS following the upgrade process.  

Step 6: Verify OneStream Application Server with OneStream Database Configuration Utility Installed 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server has the OneStream Database Configuration Utility installed.  

Step 7: Verify OneStream Application Server with OneStream Studio Installed (if applicable) 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server(s) has OneStream Studio installed.  This will need to be re-installed on the 
application server during the upgrade operation. 

 

Upgrading System Components 
The following section describes the process used to upgrade the complete OneStream XF system. 

Step 1: Stop OneStream Application Pools Prior to Uninstall  

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane. 

3.) Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and 
selecting Stop (Note: Close any open OneStream Configuration Utilities) 

4.) Repeat these steps for each server in the environment 

Step 2: Uninstall the OneStream XF Servers Package 
In order to upgrade to a new release, the previous software release must be uninstalled from all servers 
before the new release can be installed on each server in the environment. 

1.) Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the OneStream 
Servers component in the list 
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2.) Right-click on the OneStream Servers component and select Uninstall 
3.) If OneStream Studio is also installed, locate the OneStream Studio component in the list, right-click 

and select Uninstall 

Step 3: Re-Install the OneStream XF Servers Package on an Application Server 

This is the primary OneStream XF installation package. This wizard based package is used to install a 
complete server setup which includes web server, application server, and all utilities.  This can also be 
used to do a custom install which allows the user to pick and choose the appropriate components for 
the server type being built. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Application Server and Server Configuration Utility on the Select Features page and 

click Next 
Note: The Database Configuration Utility may also be chosen if the application server is the server 
where the software was installed in the previous version of OneStream XF. 

6.) Click Install to install the software and click Finish when it is complete 

Step 4: Re-Install the OneStream XF Servers Package on a Web Server 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Web Server and Server Configuration Utility on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 5: Re-Install the OneStream XF Studio Package 

1.) Browse to the OneStream Studio package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Select the installation directory where the software was previously installed 

(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next 
5.) Choose all options on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 6: Upgrade OneStream XF Framework and Application Databases  

Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application Databases) 
prior to running the schema update operation. 

1.) On the OneStream application server with the OneStream Database Configuration Utility installed, 
navigate to the utility 
Start > Programs > OneStream Software > OneStream Database Configuration Utility   

2.) Right-click on the utility and choose Run as Administrator 
3.) Right-click on the OneStream Framework Database and choose Upgrade Database Version 

Note: If this is grayed out, an upgrade to the database is not necessary 
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4.) Confirm the upgrade of the database 
5.) Repeat this process for the application database(s) as necessary 

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers, and select the 
web.config file 

4.) When the web.config opens, paste the Configuration Files Folder path 
5.) Close the file making sure to save upon closing 
6.) Repeat this process on each server in the environment 

Step 8: Update Application and Web Server Config Files 

1.) Open Application Server Configuration file and Click File > Save 
2.) Close and re-open the Application Server Configuration File 
3.) Scroll to Database Server Connections and select the ellipsis (…) icon 

• Update command Time-outs for OneStream Database Server Connection: 
o Short = 90 *must do 
o Large = 900 (minimum of 900) 

4.) Save and Close Application Server Configuration file 
5.) Open Web Server Configuration file 
6.) Click File > Save 
7.) Close Web Server Configuration file 

Step 9: Update Identity to OneStream Service Account in Internet Information Services Manager (IIS) 

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool on the 
application servers and OneStreamWebAppPool on the web servers. 

3.) Right-click on the OneStreamAppAppPool and select Advanced Settings 
4.) Click in the Identity field and select the ellipsis (…) icon 
5.) Choose Custom Account and click Set 
6.) In the username field, enter the OneStream Service Account (Domain\Username) and 

enter/confirm the corresponding password 
7.) Set Ping Enabled to False 
8.) Set the Disable Recycling For Configuration Changes setting to True 
9.) Expand the Generate Recycle Event Log Entries setting, set any of the items beneath it to True, and 

click OK 
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10.) Once this is complete, restart IIS on each OneStream server in the environment   

Step 10: Test OneStream Environment Login 

1.) Navigate to the OneStream Web URL: 
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx 

2.) Verify the ability to login to OneStream XF 
3.) Select System Administration from the application drop down list and click Connect 
4.) Navigate to Tools > Application Servers 

This will display a list of all application servers and their server status 
5.) Verify each server’s WCF Connection status is OK 
6.) Verify each server’s CPU % is updating 

Step 11: Application Verification 

7.) Compile ALL Business Rules 

• Right click grid and Export any errors to an Excel file format for analysis 

• Apply updates to Business Rules as need 
8.)  (Optional) Import new Standard Reports after downloading from Store on XF MarketPlace  

 

 


