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OneStream XF Version 5.0.0  
Release Notes 

OneStream XF 5.0 represents a major release of our platform.  This release includes the first in a series 
of performance and scalability improvements that we call “X-Scale.”  It also includes several Reporting 
and Analysis improvements, Report Alias capabilities, as well as Administrator and End User productivity 
improvements.  These Release Notes list the changes in OneStream XF, other changes in XF MarketPlace 
solutions during this timeframe and includes an Upgrade Guide.  

Release Date: March 05, 2019 
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Important Notes 

Prerequisites 
See section of this document entitled OneStream XF 5.0.0 Upgrade Guide for important notices and 
details regarding planning your upgrade. Also refer to OneStream XF version 4.5.0 Release Notes if 
upgrading from a previous release.  

Compatibility 
See the OneStream XF 5.0.0 Upgrade Guide later in this document for information on compatibility of 
the OneStream Studio and OneStream Excel Add-in versions.  

• OneStream XF Server is no longer supported on Windows Server 2008. (8443) 

• OneStream XF users are encouraged to adopt the OneStream Windows App. The OneStream XF 
web interface has been developed utilizing Microsoft’s Silverlight web browser plug-in.  
Microsoft officially announced in 2012 that development of Silverlight will be discontinued with 
support scheduled to end in October 2021.  The OneStream Windows Application is the 
replacement for the Silverlight-based browser interface.  Customers should note that certain 
new features may only be available in the OneStream Windows App due to its technology 
advantages.  In addition, users can access OneStream XF through the HTML5-based OneStream 
Mobile and OneStream Excel Add-in.  OneStream will not support the Silverlight-based web 
browser interface beyond 2021.  

Schema Update  
OneStream XF 5.0 will require a Database Schema Upgrade to be performed on the Framework and 
application databases, using the Database Configuration Utility, when upgrading from prior releases.  All 
the OneStream databases must have a complete backup performed prior to initiating the OneStream XF 
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5.0 upgrade.  Customers should anticipate the Schema Update process to take longer than the typical 
OneStream XF upgrade.   

OneStream customers, depending on application size, may want to increase the computing power of the 
OneStream database instance temporarily to ensure this process completes in a timely manner. 

The additional time to process the database scheme update is due to various updates to existing 
database tables and the creation of new database tables supporting features in this release.  As part of 
this release, Task Activity table historical records, which are within the retention configuration 
thresholds, are migrated to a new table to support a new table design.  A new standard report is 
available to report Task Activity on either historical or future records. Updates to the Standard 
Application Reports (RPTA) and Standard System Reports (RPTS) are available on the XF MarketPlace 
Store.   

OneStream XF 

X-Scale 
OneStream is delivering the first in a series of X-Scale releases to eliminate wasted server capacity and 
costs while accommodating peak loads when needed. The X-Scale environment is one having a self-
regulating, but transparent, mechanism to adjust capacity, detect anomalies, and optimize 
infrastructure usage and costs.  The results are server resources and their capacity, which are capable of 
being expanded and contracted, manually or automatically. 

Enabling the optimization of performance, and understanding the demands on the system, is done 
through the OneStream XF Smart CPM Sensors.  These sensors monitor and manage activity such as 
queueing tasks, logons, application and database server activity, and the overall health of the 
environment. Extensive metrics information is now being tracked on web, mobile and application 
servers as well as database statistics.    

A key aspect is to understand and control the OneStream XF Environment.  In this release, the new 
Environment page gives graphical insight into how your server sets and database are configured and 
performing, all directly from a single OneStream XF user interface.  

The OneStream XF 5.0 Queue-Based Smart Load Balancing X-Scale feature is tailored to monitor the 
Smart CPM sensors to assign high-resource tasks such as Consolidations, Data Management and Stage 
Tasks to the servers best suited for the task. 

The X-Scale feature set will continue to expand as the demand for efficient, performance driven systems 
continues to expand. 

• Environment Awareness 
o Collect Metrics 
o Insight between functional metrics with system metrics over chosen timeframes  

• Environment Control and Health 
o Manage performance 
o Manage servers and database 
o Configuration transparency, reducing reliance on OneStream Support 

• Smart Autonomous Servers 
o Automatic Diagnostics 
o Collaborative Task Load Balancing 

• Simplify OneStream XF Cloud Upgrades 
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New Features 

Presentation 

• Cube Views  
o A new application metadata feature now supports alternate Reporting Alias on all 

editable dimensions.  This feature allows application designers to localize applications 
for users.  The Reporting Alias descriptions are defined through a “Culture Codes” 
property in the OneStream Application Configuration Utility.  The property is then 
enabled as a metadata dimension description property, which can be used in reporting.  
The application administrator has full control on the display of the property in reporting 
as a manual setting or dynamically by being defined through each user’s Security 
Preference setting of “Culture”. (5098) 

o A new Conditional Formatting solution has been added to Cube Views to quickly and 
easily apply formats to Headers and/or Data Cells.  Conditional Formatting applied to a 
Cube View is presented in all outputs such as Data Explorer, Excel and Reporting.  As 
part of this enhancement, formatting for Header and Cell is done through a new Edit 
window where the user can directly enter the formatting definition.  Alternatively, a 
graphical interface is available using the Condition and/or Format buttons.  These 
buttons present all the syntax options available for conditional definitions and 
formatting options.  The Conditional Formatting definition can also be saved as a Literal 
Parameter and applied later to a Cube View by name. (5580),(5581), 
(5576),(5584),(5585),(8258),(8447) 

• Dashboards  
o XF Project is for OneStream XF Application Project Designers who are building solutions 

that span many OneStream XF artifacts, such as Dashboard Maintenance Units, Business 
Rules, Cubes, Dimensions, Cube Views, etc. A good example is a person designing a 
solution to be hosted on XF MarketPlace.  This application Extract and Load option 
allows all the defined objects, such as Dashboards and Business Rules, to be collected as 
a single file export package and to be later reloaded as a package.  XF Project is used as 
a convenient way to organize MarketPlace or similar solutions into a folder structure 
which can be integrated with a version control system such as “Git.” Doing so could 
enable more than one team member to work on a solution simultaneously. The 
OneStream XF developer must create an XML file which is the definition for the contents 
of the XF Project export. (5587) 

• Excel and Spreadsheet 
o Multidimensional analysis in Quick Views is now faster and more intuitive by allowing 

users the ability to directly type the row and column definitions to worksheet cells to 
initialize a Quick View.  Once initialized, direct typing definitions to cells can also be 
done to expand or modify a Quick View such as adding new members or expanding a 
hierarchy.  Direct typing also allows the users to pivot and swap dimensions between 
rows, columns and the point of view. 
(8271),(8271),(8273),(8274),(8277),(8421),(8693),(8856), (8421) 

o The Quick View Select Member toolbar button is now integrated with the selected 
worksheet member.  The default selected member returned in the dialog box will be the 
member selected as the active cell in the Quick View worksheet.  The Quick View Select 
Member toolbar button is now unique in that selections using this tool bar button will 
also apply the dimension keyword, such as “A#” as a prefix.  This feature is used to assist 
applying members to worksheets using the “direct typing to cells” method to initialize 
Quick Views.  (8831),(9759)  
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o The Quick View Point of View panel has been enhanced to display the current Cube 
POV selection, beyond only displaying the dimension type. (8275), (8272) 

o The Excel Add-In refresh performance has been enhanced with the updated Preference 
called Use Minimal Excel Calculation on Refresh.  This now applies to both the Refresh 
Worksheet and Refresh Workbook processes. This is for Excel Add-In only, not the 
Spreadsheet feature in OneStream Windows App. The default is True this will only 
calculate XF formulas and Excel functions in the active worksheet or workbook. Set to 
False to revert to a full calculation of all workbooks and all sheets.  Performance is best 
when Excel is set to use Manual Calculation Mode. (9134) 

Financial Model 

• Application performance will be increased for large server tasks, such as Consolidations, Data 
Management Tasks and Stage Loads through Smart Load Balancing.  This feature more 
efficiently assigns tasks to servers based on their current usage.  While each tasks’ processing 
time may not be shortened, less queuing and more efficient use of server resources results in 
faster overall processing of tasks. 

• The eight User Defined Dimensions can now have customized descriptions to provide the user 
with better insight into the design and context of each dimension.  This feature adds a new 
property on the Application Properties / Dimensions tab for User Defined Dimension 
Descriptions.  The descriptions are exposed in all point of view selections, dimension selectors 
and drill-downs as a display or hover tool-tip, making navigation through the selections easier. 
(7707), (7708),(7710),(8259),(9469) 

• Member Expansions can now be modified for the orientation of the parent member, allowing 
designers more flexibility in reporting.  Parent members can be positioned at the top or the 
bottom of the expansion by added the letter “R” at the end of the expansion definition.  This 
property is available on the Children, TreeDescendents expansions.  Example: 
E#ParentMember.ChildrenInclusive or E#ParentMember.ChildrenInclusiveR.(8859) 

• Two new business rule functions have been added for performance purposes, RemoveZeros and 
RemoveNoData.   These functions can be added to calculations to more efficiently process 
formulas.  Use the RemoveNoData function in calculations where there is a substantial amount 
of No Data cells in Data Units.  Use the RemoveZeros function in calculations where there is a 
substantial amount of No Data or 0.00 cells in Data Units.  These two new functions replace the 
functionality found in certain Eval helper functions.  (7626) 

• Business Rules can now be secured using password protected encryption.  This new feature can 
be enabled for application designers and XF MarketPlace developers to protect content from 
view or edit.  Supporting this feature is a new security role, EncryptBusinessRules, which 
enables the Encrypt Business Rules toolbar button. (8094), (8104), (8107), (8112), (8232), (8233), 
(8252), (8323), (8646), (8873), (10280) 

Data Integration 

Load Cube performance and data cell update processing has been greatly enhanced in OneStream XF 
5.0.  Under our test circumstances, we experienced a significant performance improvement in Stage 
Load Cube processing.  Data Cell processes, such as saving data through Excel Set Cell Formulas, Cube 
View / Forms data entry, Quick View data entry and Data Management Clear Data, are also enhanced.  

Load Cube optimization most heavily impacts the write process for “Clear” and “SaveCell” processes.  
Improved management of the DataCache TimeStamp updates provides performance and scalability 
benefits for data cell updates. (9249), (9293) 

Together, these enhancements were realized in our tests in these ways: 
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• Better performance on Load Cube times. 

• Better performance on Stage Validate Intersections when cell level security is used for a cube. 

• Better performance on Data Management Clear Data processes. 

• Better performance on data cell updates from Excel/Spreadsheet Set Cell Formulas, Cube 
Views/Forms and Quick Views 
 

Load Stage performance has been enhanced to support more efficient processing of multi-period data 
files.  The new Import has two new Load Methods: (8638) 

• Replace (All Time): This method forces a replace of all time values in a multi-period Workflow 
View.  This prevents the need to use an event Business Rule when the source file may not 
contain all time values each time the file is loaded. 

• Replace Background (All Time, All Source IDs): This method replaces all Workflow Units in the 
selected Workflow View, and all Source ID’s in a background thread, while the new file parse or 
connector execution is running. This method should not be used in situations when a partial 
replace data file is used and there are multiple Source ID’s.  This is because all the Source ID’s 
will be deleted when the process is executed.  

Foundation 

• The new page, Environment, has been added to the System tab Tools. The Environment page is 
designed to give both IT and business users a way to manage and optimize their applications 
and the environment that is running under.  Using the Environment page, the user can monitor 
the XF environment, isolate bottlenecks, look at properties and configuration changes, and scale 
in/out application servers and database resources if needed.  For more details on the 
Environment page, see the Design and Reference Guide as well as the Installation and 
Configuration Guide. 

• Queue-Based Smart Load Balance for intensive server tasks will provide better server 
utilization.  Once a task is queued, the server will and assign the task to the server that is best 
suited to run the process. Each task is evaluated for optimal utilization on the current CPU usage 
and the number of tasks running. 

• Application performance is maximized by adhering to best practices when designing Business 
Rules.  Using Microsoft’s latest .NET Roslyn compiler, OneStream XF 5.0 is exposing Warning 
Messages during the compile process.  The warning messages will write to the Error Log 
whenever the application compiles Business Rules.  These Warning Messages are designed to 
guide the customer to inefficient or incorrect rules which may impact application performance.  
Warning messages should be corrected to achieve maximum system performance.  

• The OneStream Application Server Configuration Utility now contains four new settings in the 
Monitoring section to provide the ability to define the automatic recycling of the IIS application 
pools.  These settings are AutoRecycleNumRunningHours, AutoRecycleStartHourUtc, 
AutoRecycleEndHourUtc and AutoRecycleMaxPauseTimeMins. (6412) 

Fixed 
• (6200) Dashboard Map Component Throws displays with active links and formatting using 

business rules. 

• (8677) The “&” Character is no longer a restricted character for use in Metadata for Extensible 
Documents. 

• (9240) Setting a logon agreement through the Configuration file in SSO enabled Silverlight Web 
Applications, the logon agreement will display independently from the authentication type.  

• (9302) User ID’s can be deleted from the OneStream XF Security configuration without 
impacting the audit history. 

• (9310) Selecting a top-level Workflow will automatically de-select any child Workflow. 
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• (9512) OneStream Excel Add-In Functions, such as XFGetMemberProperty, can reference a 
worksheet cell to define a formula property and will not be affected by display the cell display 
settings.   

• (8984) The OneStream Application Server Configuration Utility is updated to display an error if 
the Server Sets property for Scaling Type is set to reference a business rule, and no rule is 
assigned to the System Business Rule Name property. 

• (8824) After Scrolling tabs on a multi-tab Spreadsheet Form Templates, using the scroll buttons, 
the selected worksheet will correctly display as the active worksheet. 

• (7609) Journal export and import of *.csv files, and *.xfj templates have been enhanced to 
support Scenarios designed as Yearly, Half, Quarterly Workflow Tracking Frequency.  A new 
property has been added to the Journal Header definition, CubeTimeName to define the period 
a journal is posted within the Workflow. 

• (10344) The Workflow Certification step processing has been improved to better support 
Workflow designs with very large numbers of base input Workflows. 

Changed 

Foundation 

• The Task Activity log now includes an additional database column Assigned Time to reflect the 
time the task is assigned to a server for processing as part of Queue-Based Smart Load 
Balancing. (9496) 

• The administrator can define the function of each server on the Web Server Configuration 
Settings under Application Servers.  Each server can be designated as for “Used for 
Consolidation,” "Used for Stage," "Used for Data Management," “Used for General Access” or 
"Used for Stage Load" by assigning each as True or False.  The “Used for Consolidation” setting 
enables the server to be used in Smart Load Balancing.  (6080),(5901) 

• ConfigurationFolder key has been added to the MVC Web Configuration file. The configuration 
folder is used to point to the XF config files.  This key has been added to the MVC Web 
Configuration file with the default value as blank and is automatically populated when the 
ASP.Net Configuration file is directed to the MVC directory in the OneStream XF Server 
Configuration Utility. (6854) 

• Session ID columns has been removed from displaying in the Logon Activity Page. (9466) 

Known Issues 
• Report Preview Error in Cube View Sharing Rows/Columns with same Name in Shared Cube 

Views. (2651) 

• When opening a Workbook that contains OneStream Formulas/Cube Views/Quick Views directly 
from the file system before opening a blank Excel workbook and logging into the OneStream 
Excel Add-In, the user may receive a “Cannot run the macro ‘XFInternalSetConnectionInfo’ error. 
As a workaround, the user can open Excel, log in and then open the XLSX file, or they can launch 
the file from within OneStream if it is in the File Repository. (5024) 

• To have SSL security configured between the OneStream Application and Web Servers, 
Application Pools must use a local administrator account rather than a domain account. (4603) 

• Business Rule which contains a ~ with passed parameters will only run when the user running it 
has a Culture Code set to English. Workaround is to use a different parameter separator other 
than ~ in rules for time being. Planned for next major release. (5958) 

• Please note that the Windows 2008 Server will no longer be supported for App Server and Web 
Server in our next major planned release. On January 14, 2020, support for Windows Server 
2008 and 2008 R2 will end (8443) 
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• SAML 2.0 does not initiate an authentication flow with a username and password from the 
service provider therefore Client API authentication with SAML 2.0 is not supported. This may 
limit the automation capabilities available. (9158). 

• Excel Extensible Documents may not retain the margin and print area formatting when assigned 
to a OneStream Book of reports. (9052) 

• Viewing Dashboards in the Silverlight Web Browser which are designed to contain more than six 
levels of nested Dashboards may not render as expected.  Users encountering this issue should 
use the OneStream Windows Application interface as a solution. (10136), (10102) 

• When viewing a Spreadsheet Form in the OneStream XF Windows Application, the Ribbon 
toolbar control to Show Gridlines or Headings does not display a “check mark” when the control 
is activated.  (9895)  

• Users editing dimension hierarchies through the Silverlight-based web interface may experience 
an intermittent issue where the Dimension Library page become unavailable.  Use of the 
OneStream Windows Application is the recommended solution for application management to 
avoid this situation. (10274) 

Managing a OneStream Environment 
Management of all changes to the OneStream XF system are recommended to follow best practice 
procedures.  Whether the changes derive from a OneStream software upgrade, or through regular 
application maintenance, all changes are recommended to be first deployed and tested in a 
development environment. There are additional benefits of making a recent copy of the production 
OneStream XF Application database, renaming it and using this as a base for these changes. Search for 
“Rename Application” in the OneStream XF Installation and Configuration Guide for instructions on 
doing so. 

Prior to being deployed to a production environment, it is recommended to extract changes from the 
development environment and assess this deployment of changes in a separate test environment. See 
relevant chapters such as Extracting and Loading Dimensions.  

Deploying changes to a production environment should avoid times during high load and high 
application activity.  Changes to these types of application artifacts especially should not be performed 
against a production environment experiencing heavy activity:  

• Business Rules, whether they contain Global functions or not 

• Confirmation Rules 

• Metadata, especially when using member formulas 

Applying changes like this while the production system is under a high level of activity may have a 
negative impact on servers and have the potential to cause running processes to produce an error.  

Standard environments are recommended to schedule production changes during slow periods or non-
work hours.  Large environments should consider using the Pause functionality within the Environment 
tab to allow activity to wind down. These large environment managers should also consider the XF 
Marketplace solution, Process Blocker, which allows a pause of critical processes to perform 
maintenance on the system, without having to shut down the entire application.  Process Blocker allows 
current tasks to be completed, while any new requests are queued, allowing the changes to be applied 
safely and effectively. Once these changes are in place, it is recommended to significantly limit the 
ability for users to make such changes during high volume.  

It is key that servers get a chance to recycle for good system memory health. OneStream Servers have a 
setting to do just that after a few hours. This is set to every 2 hours by default and can be configured in 
IIS in the OneStreamAppAppPool settings in the Idle Time-out property. In a standard environment, this 



OneStream XF Version 5.0.0 Release Notes Page 8 of 15 
 

tends to happen naturally by the servers winding down after this period of inactivity. For active, global 
environments with Data Management Sequences regularly being executed, a recycle of IIS is 
recommended every 24 hours for these OneStream App Servers. Please discuss this situation with 
OneStream Support to find what is recommended, as each situation may vary.  

Contacting Support 
OneStream Support can be contacted at any time by first registering at our support site at 
http://support.onestreamsoftware.com and then emailing support@onestreamsoftware.com.  To gain 
access to the XF MarketPlace, email OneStream Support. 

 

http://support.onestreamsoftware.com/
mailto:support@onestreamsoftware.com
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OneStream XF MarketPlace Updates 

The following updates were made to XF MarketPlace solutions since the OneStream XF 4.5.0 Release in 
October 2018. Refer to the specific solution’s release notes in XF MarketPlace for more details on these 
improvements. 

New 
Tax Provision Starter Kit (TXP) 

The Tax Provision Starter Kit (TXP) solution provides OneStream customers with an integrated 
easy to manage application to automate and streamline the tax provision process within the 
OneStream XF CPM platform.  The Tax Provision Starter Kit is installed with Customer’s 
OneStream XF Financial Model Applications but will utilize its own distinct Cube within 
OneStream XF.  This provides the ability to leverage Financial Model data that may already be in 
OneStream XF, while still retaining the ability for Tax organizations to manage separate and 
distinct data and Workflow in OneStream XF. 

MarketPlace Solution Tools (MST) 

MarketPlace Solution Tools provides OneStream XF administrators a suite of features that can be used 
across different XF MarketPlace solutions. The initial version includes the Solution Copy feature as the 
first solution tool. The Solution Copy feature provides administrators with an efficient way to copy an 
existing XF MarketPlace solution enabling multiple solution instances to coexist in a single OneStream XF 
Application. This will allow flexibility to support how groupings of users manage these solutions and data 
that need to be segregated to support different business processes.  

Changed 
Diagnostics 123  

The theme for this release is OneStream XF 5.0.0 compatibility.  The XF 5.0.0 Environment Monitoring 
functionality is now used to provide source environment information for analysis and reporting in 
Diagnostics 123.  Redundant functionality has been removed from the Diagnostics 123 solution. 

Snippet Editor 

The theme of this release is new Snippets related to OneStream XF 5.0.0 functionality, such as Remove 
Zero Data and Remove NoData. Also included are best practices Snippets such as Workflow status, 
common financial logic including getting the days in a period, rename dim, metadata helpers and a 
Stage-to-Stage Connector example. 

Provision Request Manager (PRM) 

The theme of this release is minor updates and defect resolution and OneStream XF 5.0.0 compatibility. 

Task Manager  

The latest release includes OneStream XF 5.0.0 compatibility. The theme of this release is incremental 
improvements including a revamped Scorecard and a new Grid View to view and work on Tasks, Task 
Instructions, and additional Task actions. 
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User Management Console  

The theme of this User Management Console (UMC) release is compatibility with OneStream XF 5.0.0 
and minor user interface enhancements.  

Standard Application Reports (RPTA) and related retirement of Standard Metadata 
Audit (RPTMA) Solution 

The latest release includes OneStream XF 5.0.0 compatibility. This release includes the latest Standard 
Application Reports. This release is also a merger of selected Metadata Audit (RPTMA) Reports. The 
RPTMA solution will no longer be updated now that all reports are merged into this solution.  

Standard System Reports (RPTS)  

The latest release includes OneStream XF 5.0.0 compatibility. This release includes the new Archived 
Task Activity report and the latest Standard System Reports that are now saved in a new format.  

Account Reconciliations (RCM) 

The theme of this release is defect resolution with minor user interface improvements. Updated various 
interface styles and formatting.  

Reporting Compliance (TCR) 

The theme of this release is to improve Reporting Compliance to better support adjustments such as 
leasing contracts with new audit features. Added new Solution Audit feature for logging modifications to 
Register data, Allocations, Calculation Plans and a defined set of other changes.  Audit Dashboard 
reporting is provided to review Solution Audit changes.  There were also other minor improvements and 
defect resolution. 

Parcel Service (OPS) 

The theme of this release is defect resolution with minor improvements (folder management).  
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OneStream XF 5.0.0 Upgrade Guide 

This document provides an overview of OneStream XF’s upgrade process when moving from an earlier 
OneStream XF release to 5.0.0. The anticipated audience for the upgrade process is Information 
Technology professionals responsible for installing, maintaining and supporting OneStream XF.    

Review the following OneStream XF 5.0.0 requirements prior to scheduling an upgrade and any related 
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.  

1.) If upgrading from OneStream XF version 4.1.x or earlier, OneStream updated to .NET 4.7 to stay 
current on the latest version of the .NET Framework, which is required for Microsoft’s security 
standards and for advanced features.  Please note, Microsoft provides the .NET Framework 4.7 
optional update through standard Microsoft Windows Updates.   

2.) The most recent database schema update was 4.2.0. There is a need for a database schema update 
if upgrading from 4.2.x or 4.3.x to version 5.0.0. If upgrading from a version 4.2.0 or earlier, 
Database Schema updates must be implemented as part of the upgrade on every Application and 
Framework database. Full Database Backups are required. 

3.) The 5.0.0 version of the OneStream Studio and OneStream Excel Add-in are not backward 
compatible with prior versions and must be updated. These either need to be uninstalled and 
reinstalled or use the Client Updater. See OneStream XF Installation and Configuration Guide for 
details under the section “Upgrade or Downgrade via OneStream.”  

4.) If upgrading from a version 4.2.0 or earlier, it is required that all OneStream Applications complete 
the Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade 
process.  

Scheduling the Upgrade 
It is recommended that this upgrade be performed by the OneStream Software Technical Support Team.  
Contact OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com. 

Pre-Installation Upgrade Checklist 
The checklist below details the items that should be completed prior to beginning the upgrade 
operation: 

Step 1: Perform a full backup of all OneStream databases. 

Step 2: App Pool Service Account must use an Administrator ID or be added to the Performance 
Monitors User Group and Performance Log Users Group.  

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace 

1.) Login to the OneStream XF MarketPlace and select Software Download in order to access the latest 
version of OneStream XF. 

2.) Download the Full Package or Server Software to acquire the appropriate setup files for the server 
installation. 

Step 4: Verify the Location of the OneStream XF Configuration Files 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 

mailto:support@onestreamsoftware.com
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3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 
Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb, on web servers, and choose the 
web.config file 

4.) The web.config will open and display the path to the corresponding configuration files: 
XFAppServerConfig.xml and XFWebServerConfig.xml 

5.) Take a copy of the config file 
6.) Copy and paste the configuration file path in a place that is easily accessible as this will need to be 

re-entered following the upgrade process 
7.) Close the file, and select No when prompted to save  
8.) Close the OneStream Server Configuration Utility 

Step 5: Verify the OneStream Service Account in Internet Information Services Manager (IIS) 

1.) Service Account must be an Admin ID or in the Performance Log User and Performance Monitor 
Users groups. 
This ID is necessary to use Queuing and CPU Monitoring. 

2.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

3.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and 
OneStreamWebAppPool are displayed in the Identity column.  Note this windows account and its 
password as this will need to be re-entered in IIS following the upgrade process.  

Step 6: Verify OneStream Application Server with OneStream Database Configuration Utility Installed 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server has the OneStream Database Configuration Utility installed.  

Step 7: Verify OneStream Application Server with OneStream Studio Installed (if applicable) 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server(s) has OneStream Studio installed.  This will need to be re-installed on the 
application server during the upgrade operation. 

 

Upgrading System Components 
The following section describes the process used to upgrade the complete OneStream XF system. 

Step 1: Stop OneStream Application Pools Prior to Uninstall  

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane. 

3.) Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and 
selecting Stop (Note: Close any open OneStream Configuration Utilities) 

4.) Repeat these steps for each server in the environment 

Step 2: Uninstall the OneStream XF Servers Package 
In order to upgrade to a new release, the previous software release must be uninstalled from all servers 
before the new release can be installed on each server in the environment. 
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1.) Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the OneStream 
Servers component in the list 

2.) Right-click on the OneStream Servers component and select Uninstall 
3.) If OneStream Studio is also installed, locate the OneStream Studio component in the list, right-click 

and select Uninstall 

Step 3: Re-Install the OneStream XF Servers Package on an Application Server 

This is the primary OneStream XF installation package. This wizard based package is used to install a 
complete server setup which includes web server, application server, and all utilities.  This can also be 
used to do a custom install which allows the user to pick and choose the appropriate components for 
the server type being built. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Application Server and Server Configuration Utility on the Select Features page and 

click Next 
Note: The Database Configuration Utility may also be chosen if the application server is the server 
where the software was installed in the previous version of OneStream XF. 

6.) Click Install to install the software and click Finish when it is complete 

Step 4: Re-Install the OneStream XF Servers Package on a Web Server 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Web Server and Server Configuration Utility on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 5: Re-Install the OneStream XF Studio Package 

1.) Browse to the OneStream Studio package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Select the installation directory where the software was previously installed 

(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next 
5.) Choose all options on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 6: Upgrade OneStream XF Framework and Application Databases  

Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application Databases) 
prior to running the schema update operation. 

1.) On the OneStream application server with the OneStream Database Configuration Utility installed, 
navigate to the utility 
Start > Programs > OneStream Software > OneStream Database Configuration Utility   

2.) Right-click on the utility and choose Run as Administrator 



OneStream XF Version 5.0.0 Release Notes Page 14 of 15 
 

3.) Right-click on the OneStream Framework Database and choose Upgrade Database Version 
Note: If this is grayed out, an upgrade to the database is not necessary 

4.) Confirm the upgrade of the database 
5.) Repeat this process for the application database(s) as necessary 

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers, and select the 
web.config file 

4.) When the web.config opens, paste the Configuration Files Folder path 
5.) Close the file making sure to save upon closing 
6.) Repeat this process on each server in the environment 

Step 8: Update Application and Web Server Config Files 

1.) Open Application Server Configuration file and Click File > Save 
2.) Close and re-open the Application Server Configuration File 
3.) Scroll to Database Server Connections and select the ellipsis (…) icon 

• Update command Time-outs for OneStream Database Server Connection: 
o Short = 90 *must do 
o Large = 900 (minimum of 900) 

4.) Save and Close Application Server Configuration file 
5.) Open Web Server Configuration file 
6.) Click File > Save 
7.) Close Web Server Configuration file 

Step 9: Update Identity to OneStream Service Account in Internet Information Services Manager (IIS) 

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool on the 
application servers and OneStreamWebAppPool on the web servers. 

3.) Right-click on the OneStreamAppAppPool and select Advanced Settings 
4.) Click in the Identity field and select the ellipsis (…) icon 
5.) Choose Custom Account and click Set 
6.) In the username field, enter the OneStream Service Account (Domain\Username) and 

enter/confirm the corresponding password 
7.) Set Ping Enabled to False 
8.) Set the Disable Recycling For Configuration Changes setting to True 
9.) Expand the Generate Recycle Event Log Entries setting, set any of the items beneath it to True, and 

click OK 
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10.) Once this is complete, restart IIS on each OneStream server in the environment   

Step 10: Test OneStream Environment Login 

1.) Navigate to the OneStream Web URL: 
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx 

2.) Verify the ability to login to OneStream XF 
3.) Select System Administration from the application drop down list and click Connect 
4.) Navigate to Tools > Application Servers 

This will display a list of all application servers and their server status 
5.) Verify each server’s WCF Connection status is OK 
6.) Verify each server’s CPU % is updating 

Step 11: Application Verification 

7.) Compile ALL Business Rules 

• Right click grid and Export any errors to an Excel file format for analysis 

• Apply updates to Business Rules as need 
8.)  (Optional) Import new Standard Reports after downloading from Store on XF MarketPlace  

 


