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OneStream XF Version 5.1.0  
Release Notes 

This release includes features to expand the capabilities and performance in reporting on ever larger 
data sets.  Improvements including Attribute Members and extended intercompany elimination options 
allow for financial modeling efficiency and flexibility.  These Release Notes list the changes in OneStream 
XF, other changes in XF MarketPlace solutions during this timeframe and includes an Upgrade Guide.  

Release Date: June 14, 2019 
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Important Notes 

Prerequisites 
See section of this document entitled OneStream XF 5.1.0 Upgrade Guide for important notices and 
details regarding planning your upgrade. Also refer to OneStream XF version 5.0.0 Release Notes if 
upgrading from a previous release.  

Compatibility 
See the OneStream XF 5.1.0 Upgrade Guide later in this document for information on compatibility of 
the OneStream Studio and OneStream Excel Add-in versions.  

OneStream XF users are encouraged to adopt the OneStream Windows App. The OneStream XF web 
interface has been developed utilizing Microsoft’s Silverlight web browser plug-in.  Microsoft officially 
announced in 2012 that development of Silverlight will be discontinued with support scheduled to end 
in October 2021.  The OneStream Windows Application is the replacement for the Silverlight-based 
browser interface.  Customers should note that certain new features may only be available in the 
OneStream Windows App due to its technology advantages.  In addition, users can access OneStream XF 
through the HTML5-based OneStream Mobile and OneStream Excel Add-in.  OneStream will not support 
the Silverlight-based web browser interface beyond 2021.  

Schema Update  
OneStream XF 5.1 will require a Database Schema Upgrade to be performed on the Framework and 
application databases when upgrading a version prior to 5.0.0, using the OneStream Database 
Configuration Utility.  Customers upgrading from versions prior to OneStream XF 5.0.0 should first 
review the OneStream XF 5.0.0 release notes. If upgrading from OneStream XF version 5.0.0 or newer, 
no Database Schema Update is required.  
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OneStream XF 

New Features 

Presentation 

Cube Views 

• Significant improvements have been done in the design and functionality of Cube View 
Sparse Data Suppression.   The new design has a more efficient algorithm to evaluate more 
intersections faster as well as allow Data Unit members on the rows, such as the Entity 
dimension. This allows even greater flexibility in the design and performance of Cube Views 
for analytic reporting. (8833), (11316), (10437), (10477), (11447) 

• Cube View performance on large data sets has been enhanced through an all new Paging 
feature.  This feature is enabled automatically as large Cube Views are being processed and 
performance is enhanced through enabling a subset of rows to be presented, rather than 
requiring all rows be returned prior to rendering the Cube View. Note that this feature is 
limited to Cube Views presented via the Data Explorer grid or Data Explorer Reports. 
Support for paging of Cube View data within Quick Views or as embedded Cube Views in 
either the Excel Add-in or Spreadsheet feature are being considered for a future release. 
(10713) 

• Conditional Formatting has a new Criteria, RelativeRowNum, which is used to evaluate Cell 
Data in expanding rows, by row.  The count for the RelativeRowNum restarts its count on 
each row.  (9719) 

Dashboards 

• For convenience of authoring Dashboards, the new Dashboard Components will default to 
the Type selected in the Dashboard Maintenance Unit Components group. (9610)   

Tools 

• In order to load more quickly, the OneStream Windows Application Text Editor and 
Spreadsheet feature user interface has been enhanced to use high resolution graphics for 
the ribbon buttons. (9128), (9129), (9130), (9131) 

Quick Views 

• For faster creation and modification, the Quick View Type-In feature now includes the 
ability to generate a manual list of members by typing a comma delimited list of members 
to update existing and new Quick Views. Also using comma delimited list of members to 
extend past an existing dimension, and type over members of the same Dimension to 
insert new members. (9918), (10086), (10088) 

Data Integration  

• A new type of Derivative Transformation Rule has been created named Target Derivative 
Rules.  This type mirrors the same functionality of the traditional derivative rules, Source 
Derivative Rules, only they occur after Transformation Rules have completed.  This allows 
groups and checks to occur using the target member names. (10490)  
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Financial Model 

• Two-Pass Elimination: A new Business Rule function, IsSecondPassEliminationCalc, has been 
created to simplify development of complex statutory business rules.  This new function is 
designed to ensure sibling Entities are calculated through to the Consolidation Elimination 
member when being referenced in a calculation.  As part of this feature, a new Scenario 
property has been added, Use Two Pass Elimination True/False.  (10337), (4507) 

• The Financial Model can now be expanded for reporting and analysis with User Defined 
Dimension members created as Attribute Members.  The User Defined member as Attribute can 
support a relationship definition against up to two application dimensions.  This new User 
Defined Dimension Member Property allows the member to reference another dimension’s 
property, such as Name, Description or Text Field, to dynamically render data as a member for 
reporting.  The Attribute Member calculates/aggregates on-the-fly in a dynamic nature yet can 
be referenced in Business Rules and will process using Sparse Data Suppression in Cube Views. 
(11122), (10441), (11338) 

• Data Management, such as copying/moving data with Business Rules, in applications utilizing 
Extensible Dimensionality can now manage data intersections with differing dimensionality.  
This is accomplished with an optional sourceEntity parameter in 
api.Data.ConvertDataBufferExtendedMembers and api.Data.ConvertDataBuffer to allow the 
rules to address dimensional variations. (10281) 

• Customized User Defined Descriptions will now display as a tool tip message in the Excel and 
Spreadsheet Select Member Dialog Box. (9805), (9977) 

• Entity Dimension Library caching has been enhanced to significantly improve performance when 
managing and editing very large Entity Dimensions. (11502) 

Foundation 

• SSO error messaging has been updated to reflect removal of deprecated external authentication 
preferences. (8836) 

• The SMTP Connection String has been modified to apply a single “FromAddress” to support 
multiple service accounts and users. (3145) 

• OneStream XF now supports Secure MSAD Authentication. (6452) 

• Azure Active Directory authentication has been updated to meet new endpoint changes 
implemented by Microsoft. (11203) 

Fixed 
• SAML authentication when using native applications (i.e. OneStream Windows App, OneStream 

Studio, Excel Add-in) is now more flexible by ignoring the SAMLResponse order, followed by a 
RelayState, in order to support customized SAML environments. (11263) 

• Data Management Sequences containing Steps using Business Rules will now be supported by 
collaborative app server queueing, which creates a queued task that will be considered by all of 
the Data Management servers, not just the server that is running the Business Rule that called 
the function.  This process will ensure that Data Management Sequence is completed in the 
most efficient manner. (11007) 

• Dashboard Buttons designed to execute Consolidation tasks are now enabled to function for 
Consolidate, Force Consolidate or Consolidate processes with logging. (10851) 

• Cube View Conditional Formatting now supports complex conditions using multiple “OR” 
conditional expressions. (10776) 

• The OneStream Environment Page logging is more accurate under heavy load conditions by 
managing a default time for SQL Blocking as a setting in the OneStream Application Server 
Configuration, SQL Blocking Time Out Interval. (10385) 
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• When reverting Spreadsheet-based Forms in Workflow from an unlocked state, the Form no 
longer requires a “refresh” to save data. (8649) 

• The SubPeriodPriorN and related offset Substitution Variables will display the correct sub-
period when used with a dynamic time function. (9279) 

• Spreadsheet-based Forms will no longer need to be refreshed to prevent data entry after the 
form is completed. (9316) 

• The Workflow Certification Step processing has been improved to better support Workflow 
designs with very large numbers of base input members. (10368)  

• Dialog Boxes in Workflow Workspaces will auto-close or allow an option to be manually closed. 
(7314) 

• Cube View Conditional Formatting conditions using IF, AND, OR and ELSE, no longer conflict with 
target conditions containing the same character string.  Any target that equals the reserved 
characters “If”,”Else”, “ElseIf”, “Then” or “EndIf”, must be enclosed in brackets. (10777), (11485) 

• The Dimension Page now lists multiple Entity Dimensions in alphabetical order. (11226) 

• File Explorer download for Download Selected File will prompt the user for a “save as” option to 
select a destination location. (11274) 

• Dashboard Button Components having a blank Text field will use the button name and will 
remove any underscores.  When creating a Text field, the first character after an underscore will 
become a hotkey. (10702)  

• Quotation marks will enclose the field of an exported Transformation rule as a *.TRX file to all it 
to items such as Descriptions to contain characters such as commas. (2378) 

Known Issues 
• Navigation in Workflow from one base input (e.g. Forms) back to another previously selected 

base input step (e.g. Import input and Transform step) may require a second click to drive a 
refresh of this page if the grid was previously filtered. (10902) 

• Report Preview Error in Cube View Sharing Rows/Columns with same Name in Shared Cube 
Views. (2651) 

• When opening a Workbook that contains OneStream Formulas/Cube Views/Quick Views directly 
from the file system before opening a blank Excel workbook and logging into the OneStream 
Excel Add-In, the user may receive a “Cannot run the macro ‘XFInternalSetConnectionInfo’ error. 
As a workaround, the user can open Excel, log in and then open the XLSX file, or they can launch 
the file from within OneStream if it is in the File Repository. (5024) 

• To have SSL security configured between the OneStream Application and Web Servers, 
Application Pools must use a local administrator account rather than a domain account. (4603) 

• Business Rule which contains a ~ with passed parameters will only run when the user running it 
has a Culture Code set to English. Workaround is to use a different parameter separator other 
than ~ in rules for time being. Planned for next major release. (5958) 

• Please note that the Windows 2008 Server will no longer be supported for App Server and Web 
Server in our next major planned release. On January 14, 2020, support for Windows Server 
2008 and 2008 R2 will end (8443) 

• Excel Extensible Documents may not retain the margin and print area formatting when assigned 
to a OneStream Book of reports. (9052) 

• Viewing Dashboards in the Silverlight Web Browser which are designed to contain more than six 
levels of nested Dashboards may not render as expected.  Users encountering this issue should 
use the OneStream Windows Application interface as a solution. (10136), (10102) 

• When viewing a Spreadsheet Form in the OneStream XF Windows Application, the Ribbon 
toolbar control to Show Gridlines or Headings does not display a “check mark” when the control 
is activated.  (9663)  
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• Users editing dimension hierarchies through the Silverlight-based web interface may experience 
an intermittent issue where the Dimension Library page become unavailable.  Use of the 
OneStream Windows Application is the recommended solution for application management to 
avoid this situation. (10274) 

Contacting Support 
OneStream Support can be contacted at any time by first registering at our support site at 
http://support.onestreamsoftware.com and then emailing support@onestreamsoftware.com.  To gain 
access to the XF MarketPlace, email OneStream Support. 

 

http://support.onestreamsoftware.com/
mailto:support@onestreamsoftware.com
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OneStream XF MarketPlace Updates 

The following updates were made to XF MarketPlace solutions since the release of OneStream XF 5.0.0. 

Note: If using any of these XF MarketPlace solutions prior to upgrading to OneStream XF 5.1.x, it is 
required to upgrade to these solution versions or higher for compatibility purposes:  

• Standard Reports (RPTA) – PV440 SV100 

• Provision Request Manager (PRM) – PV440 SV104 

New 
End User Training Videos 

The End User Training Videos (EUTV) Solution is a package of training videos that is designed for 
Administrators or Consultants to download and provide to end users. 

Changed 
Account Reconciliations   

Minor defect resolution, maintenance, and user improvement features.  

• Reconciliation Certifications 

• Primary Preparers and Approvers 

• A consolidated Reconciliation Report for the All Audit packages 

• Plus, over a dozen other enhancements and fixes 

Provision Request Manager 

The theme of this release is OneStream XF 5.0.4 and 5.1.0 compatibility and maintenance. The client 
APIs were added to support the 5.0.4 and 5.1.0 versions.  

Specialty Planning & Specialty Compliance Solutions 

Multiple releases of these eight solutions. The release themes included incremental improvements and 
minor defect correction to all of the Specialty Planning and Specialty Compliance solutions.  
Improvements include a Solution Audit feature and reporting enhancements. All of these solutions will 
now be documented in a common set of shared documents. 

Standard Application Reports 

The theme of this release is updating RPTA to the latest OneStream XF MarketPlace Solution Standards 
using a single XF Dashboard Maintenance Unit and matching the Security Audit Reports Dashboard User 
Interface. 

Task Manager  

Minor defect resolution.  

Excel Add-in Installer 

Updated solution to current OneStream XF MarketPlace standards and added support for referencing 
the OneStream XF Studio client.  
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OneStream XF 5.1.0 Upgrade Guide 

This document provides an overview of OneStream XF’s upgrade process when moving from an earlier 
OneStream XF release to 5.1.0. The anticipated audience for the upgrade process is Information 
Technology professionals responsible for installing, maintaining and supporting OneStream XF.    

Review the following OneStream XF 5.1.0 requirements prior to scheduling an upgrade and any related 
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.  

1.) If upgrading from OneStream XF version 4.1.x or earlier, OneStream updated to .NET 4.7 to stay 
current on the latest version of the .NET Framework, which is required for Microsoft’s security 
standards and for advanced features.  Please note, Microsoft provides the .NET Framework 4.7 
optional update through standard Microsoft Windows Updates.   

2.) The most recent database schema update was 4.2.0. There is a need for a database schema update 
if upgrading from 4.2.x or 4.3.x to version 5.0.0. If upgrading from a version 4.2.0 or earlier, 
Database Schema updates must be implemented as part of the upgrade on every Application and 
Framework database. Full Database Backups are required. 

3.) The 5.1.0 version of the OneStream Studio and OneStream Excel Add-in are not backward 
compatible with versions to 5.0 and must be updated. These either need to be uninstalled and 
reinstalled or use the Client Updater. See OneStream XF Installation and Configuration Guide for 
details under the section “Upgrade or Downgrade via OneStream.”  

4.) If upgrading from a version 4.2.0 or earlier, it is required that all OneStream Applications complete 
the Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade 
process.  

Scheduling the Upgrade 
It is recommended that this upgrade be performed by the OneStream Software Technical Support Team.  
Contact OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com. 

Pre-Installation Upgrade Checklist 
The checklist below details the items that should be completed prior to beginning the upgrade 
operation: 

Step 1: Perform a full backup of all OneStream databases. 

Step 2: App Pool Service Account must use an Administrator ID or be added to the Performance 
Monitors User Group and Performance Log Users Group.  

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace 

1.) Login to the OneStream XF MarketPlace and select Software Download in order to access the latest 
version of OneStream XF. 

2.) Download the Full Package or Server Software to acquire the appropriate setup files for the server 
installation. 

Step 4: Verify the Location of the OneStream XF Configuration Files 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 

mailto:support@onestreamsoftware.com


 

OneStream XF Version 5.1.0 Release Notes Page 8 of 11 
 

3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 
Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb, on web servers, and choose the 
web.config file 

4.) The web.config will open and display the path to the corresponding configuration files: 
XFAppServerConfig.xml and XFWebServerConfig.xml 

5.) Take a copy of the config file 
6.) Copy and paste the configuration file path in a place that is easily accessible as this will need to be 

re-entered following the upgrade process 
7.) Close the file, and select No when prompted to save  
8.) Close the OneStream Server Configuration Utility 

Step 5: Verify the OneStream Service Account in Internet Information Services Manager (IIS) 

1.) Service Account must be an Admin ID or in the Performance Log User and Performance Monitor 
Users groups. 
This ID is necessary to use Queuing and CPU Monitoring. 

2.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

3.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and 
OneStreamWebAppPool are displayed in the Identity column.  Note this windows account and its 
password as this will need to be re-entered in IIS following the upgrade process.  

Step 6: Verify OneStream Application Server with OneStream Database Configuration Utility Installed 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server has the OneStream Database Configuration Utility installed.  

Step 7: Verify OneStream Application Server with OneStream Studio Installed (if applicable) 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server(s) has OneStream Studio installed.  This will need to be re-installed on the 
application server during the upgrade operation. 

 

Upgrading System Components 
The following section describes the process used to upgrade the complete OneStream XF system. 

Step 1: Stop OneStream Application Pools Prior to Uninstall  

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane. 

3.) Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and 
selecting Stop (Note: Close any open OneStream Configuration Utilities) 

4.) Repeat these steps for each server in the environment 

Step 2: Uninstall the OneStream XF Servers Package 
In order to upgrade to a new release, the previous software release must be uninstalled from all servers 
before the new release can be installed on each server in the environment. 
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1.) Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the OneStream 
Servers component in the list 

2.) Right-click on the OneStream Servers component and select Uninstall 
3.) If OneStream Studio is also installed, locate the OneStream Studio component in the list, right-click 

and select Uninstall 

Step 3: Re-Install the OneStream XF Servers Package on an Application Server 

This is the primary OneStream XF installation package. This wizard based package is used to install a 
complete server setup which includes web server, application server, and all utilities.  This can also be 
used to do a custom install which allows the user to pick and choose the appropriate components for 
the server type being built. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Application Server and Server Configuration Utility on the Select Features page and 

click Next 
Note: The Database Configuration Utility may also be chosen if the application server is the server 
where the software was installed in the previous version of OneStream XF. 

6.) Click Install to install the software and click Finish when it is complete 

Step 4: Re-Install the OneStream XF Servers Package on a Web Server 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Web Server and Server Configuration Utility on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 5: Re-Install the OneStream XF Studio Package 

1.) Browse to the OneStream Studio package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Select the installation directory where the software was previously installed 

(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next 
5.) Choose all options on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 6: Upgrade OneStream XF Framework and Application Databases  

Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application Databases) 
prior to running the schema update operation. 

1.) On the OneStream application server with the OneStream Database Configuration Utility installed, 
navigate to the utility 
Start > Programs > OneStream Software > OneStream Database Configuration Utility   
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2.) Right-click on the utility and choose Run as Administrator 
3.) Right-click on the OneStream Framework Database and choose Upgrade Database Version 

Note: If this is grayed out, an upgrade to the database is not necessary 
4.) Confirm the upgrade of the database 
5.) Repeat this process for the application database(s) as necessary 

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers, and select the 
web.config file 

4.) When the web.config opens, paste the Configuration Files Folder path 
5.) Close the file making sure to save upon closing 
6.) Repeat this process on each server in the environment 

Step 8: Update Application and Web Server Config Files 

1.) Open Application Server Configuration file and Click File > Save 
2.) Close and re-open the Application Server Configuration File 
3.) Scroll to Database Server Connections and select the ellipsis (…) icon 

• Update command Time-outs for OneStream Database Server Connection: 
o Short = 90 *must do 
o Large = 900 (minimum of 900) 

4.) Save and Close Application Server Configuration file 
5.) Open Web Server Configuration file 
6.) Click File > Save 
7.) Close Web Server Configuration file 

Step 9: Update Identity to OneStream Service Account in Internet Information Services Manager (IIS) 

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool on the 
application servers and OneStreamWebAppPool on the web servers. 

3.) Right-click on the OneStreamAppAppPool and select Advanced Settings 
4.) Click in the Identity field and select the ellipsis (…) icon 
5.) Choose Custom Account and click Set 
6.) In the username field, enter the OneStream Service Account (Domain\Username) and 

enter/confirm the corresponding password 
7.) Set Ping Enabled to False 
8.) Set the Disable Recycling For Configuration Changes setting to True 
9.) Expand the Generate Recycle Event Log Entries setting, set any of the items beneath it to True, and 

click OK 
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10.) Once this is complete, restart IIS on each OneStream server in the environment   

Step 10: Test OneStream Environment Login 

1.) Navigate to the OneStream Web URL: 
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx 

2.) Verify the ability to login to OneStream XF 
3.) Select System Administration from the application drop down list and click Connect 
4.) Navigate to Tools > Application Servers 

This will display a list of all application servers and their server status 
5.) Verify each server’s WCF Connection status is OK 
6.) Verify each server’s CPU % is updating 

Step 11: Application Verification 

7.) Compile ALL Business Rules 

• Right click grid and Export any errors to an Excel file format for analysis 

• Apply updates to Business Rules as need 
8.)  (Optional) Import new Standard Reports after downloading from Store on XF MarketPlace  

 


