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OneStream XF Version 5.2.0 
Release Notes 

Release Date: October 11, 2019 

This is a major release that includes features to expand the analytic reporting capabilities and 
performance on reporting larger data sets.  Improvements include a BI Blend solution for high 
performance, analytic reporting, BI Dashboards to provide drag-and-drop functionality to quickly create 
interactive visualizations and REST API designed to expose OneStream Client API for interaction with 
third-party applications. It also includes several Reporting and Analysis improvements as well as 
Administrator and End User productivity improvements. The attached Release Notes list the changes in 
OneStream XF, other changes in XF MarketPlace solutions during this timeframe and includes an 
Upgrade Guide.  
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Important Notes 

Prerequisites 
See section of this document entitled OneStream XF 5.2.0 Upgrade Guide for important notices and 
details regarding planning your upgrade.  

Documentation - New 
Note: All new supplemental documentation is being delivered separately. These new documents will be 
available for download on the MarketPlace. 

• OneStream XF BI Viewer Design and Reference Guide 

• BI Blend Design and Reference Guide 

• Supplemental Large Data Pivot Grid Guide 

• Supplemental Guide - Pivot Grid 

• TableViews Design and Reference Guide 

Compatibility 
See the OneStream XF 5.2.0 Upgrade Guide later in this document for information on compatibility of 
the OneStream Studio and OneStream Excel Add-in versions.  

OneStream XF users are encouraged to adopt the OneStream Windows App. The OneStream XF web 
interface has been developed utilizing Microsoft’s Silverlight web browser plug-in.  Microsoft officially 
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announced in 2012 that development of Silverlight will be discontinued with support scheduled to end 
in October 2021.  The OneStream Windows Application is the replacement for the Silverlight-based 
browser interface.  Customers should note that certain new features may only be available in the 
OneStream Windows App due to its technology advantages.  In addition, users can access OneStream XF 
through the HTML5-based OneStream Mobile and OneStream Excel Add-in.  OneStream will not support 
the Silverlight-based web browser interface beyond 2021.  

Please note that the Windows 2008 Server will no longer be supported for App Server and Web Server in 
our next major planned release. On January 14, 2020, support for Windows Server 2008 and 2008 R2 
will end. 

Schema Update  
OneStream XF 5.2.0 will require a Database Schema Upgrade to be performed on the Framework and 
application databases when upgrading a version 5.1.1 and prior, using the OneStream Database 
Configuration Utility.   

OneStream XF 

New Features 

BI Blend 

BI Blend is an innovative approach to providing a solution for high performance, analytic reporting.   BI 
Blend is a “read-only” aggregate storage model to support reporting on large volumes of data that may 
not be appropriate to store in a traditional OneStream XF Cube.  The BI Blend Engine is specifically 
designed to manage data that is large in volume and most often transactional in nature.   

BI Blend approaches these challenges in a unique and innovate way.  It rationalizes the source data for 
uniform and standardized reporting, much like the Standard OneStream XF Cube models, but stores the 
data in a new relational column store table for responsive reporting.  

The BI Blend solution is intended to support analytics on large volumes of highly changing data, such as 
ERP system data, which typically would not reside in a OneStream XF Cube.  The processing is 
unencumbered from the intensive audit controls within a traditional Consolidation Cube, such as 
managing Calculation Status. 

BI Blend is intended to support a blend of Multidimensional and Transactional Data.  This is done by 
utilizing the OneStream XF Platform application to generate a database surface for OLAP reporting.  By 
utilizing the existing OneStream Workflow processes, users will be familiar with the interface and tools 
required to develop BI Blend reporting solutions, needing no additional training.  

BI Viewer 

BI Viewer is a new Dashboard Component that renders a dashboard experience that contains rich, 
intuitive graphics.  It is used to quickly create a Business Intelligence (BI) visualization of data from 
existing or new Data Adapters. The user can quickly create BI Dashboards that will allow the user to 
visualize and analyze data.  

BI Dashboards are a powerful tool and allow the user to dynamically add data and build Charts, Gauges, 
Maps, Grids, Cards, and much more. This BI component integrates well with the Cube View MD Data 
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adapter, allows the user at design time to; Add Calculated fields to the Data Source to create new fields 
and measures, design a path for Drill Down, Multi-Select filtering and Conditional formatting for 
dynamic viewing at runtime and provides the ability to Customize Palette Colors. 

  

Presentation 

Quick Views 

• When inserting Comma Separated List to an existing Quick View, the list retains the location and 
the order of where list was entered. (11883,11755) 

Dashboards 

• Pivot Grid Standard (Windows App Only) is a new Dashboard that allows users to create a pivot 
table, utilizing data from any existing and new Data Adapters to perform multi-dimensional 
analysis. At runtime, the user can customize the layout of the report using simple drag-and-drop 
operations and conditional formatting based on their analysis requirements. In the Pivot Grid, 
data can be summarized, calculated fields (text and decimal) can be added and displayed in a 
cross-tabular format that can be sorted, grouped and filtered. 

• The Large Data Pivot Grid is a new Dashboard Component which supports connecting to 
external tables or large database tables for “pivot” style analytic reporting. The Large Data Pivot 
Grid allows the designer to integrate data, found in external tables, seamlessly into the 
OneStream environment through a Dashboard for analytic reporting. The Large Data Pivot Grid’s 
Paging feature and Server-Based Processing enables the component to manage very large data 
sets/tables. (11123) 

• Cube View Multi-Dimensional Adapter is a new Command Type that will return the selected 
Cube View as an in-memory Multi-Dimensional fact table that renders user friendly table 
column naming. This simplifies the report building process in the BI Designer, Pivot Grid, Report 
Studio and Dashboard development. There are also additional Loop Parameter options that can 
be selected here to include incremental information from the modified Cube View definition in 
the resulting tables. 

• BI Blend Adapter is specifically designed to query data from BI Blend tables to create 
OneStream XF Dashboards.  This new adapter simplifies the defining the queries to the external 
BI Blend tables. (11891) 

• To support rich interaction in XF MarketPlace solutions, the SQL Table Editor supports the ability 
to pass multiple selections, Multiselect, to the Component’s Bound Parameter.  This allows 
complex interactive dashboards to be designed based off activations in the SQL Table Editor. 
(12383, 11730, 10574, 12427) 

• Users are now able tailor the presentation of content in the SQL Table Editor by setting the 
order, column width and visibility of columns. (11349, 11731, 12432) 

• A new Save State property has been added to the SQL Table Editor. This setting will preserve 
the user’s selections and settings for Column Order, Visible Columns, Column Width and Column 
Filters in each instance of a SQL Table Editor Component. (12319, 12048) 

• Copy Dashboard Component button added to copy any Dashboard Component in the 
Component menu. The new button brings up dialog to name new component and specify 
dashboard group. (11414) 
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Tools 

• Spell Check has been implemented for the Text Editor and Data Cell Attachments.  This is a 
OneStream Windows Application feature which is enabled on the Application/Tools/Text Editor 
from the Review ribbon.  When in the edit mode of Data Attachments, the Spell Check feature 
will provide active Spell Checking, provide users with suggested solutions and allow updates to 
the user’s custom dictionary. (12189,13150,12216) 

Spreadsheet 

• Table Views is a new tool for use with the Spreadsheet control.  Table Views is a solution for 
advanced Dashboard designers to create Dashboards using Spreadsheet to present datasets 
from a variety of sources, such as relational tables. The use of Table Views in Spreadsheet 
enables the designer to work in a more flexible environment to design a form or data collection 
tool. (9012) 

Reporting 

• (11819) A new Cube View Report Formatting property has been added, 
ReportIncludePageHeader and ReportIncludeColumnHeaderLine.  These setting will set the 
Cube View to suppress the headers in Reporting Views yet retain the Column Headers.   

Business Rules 

• New Business Rule BRAPI’s have been added to enhance performance when creating Metadata 
using Business Rules.  ReadDimNoCache and ReadMemberNoCache will read direct from the 
database, bypassing caching.  This can be used in place of GetDim() and GetMember() to read 
directly from the database when very large metadata structures impact business rule 
performance. (14091)  

Foundation 

• REST API - OneStream Web API is a RESTful web service designed to expose OneStream Data 
Automation functions when interacting with third-party API client applications.  
OneStream Web API must be installed on a web server and be configured for external 
authentication providers supporting OAuth2.0/OpenID Connect authorization protocol. Identity 
Providers currently supported are Okta, Azure AD and PingFederate. 
OneStream Web API is API client agnostic. It accepts and outputs data in JSON format making it 
possible for every API client application that supports this format to also interact with this 
service. (8997) 

• The System / Environment page now has a button to allow system Administrators to manually 
recycle the IIS Web Application Pools. (12378) 

• Single Sign On has been enhanced for OKTA/AzureAD to retain their login session for OneStream 
XF.  (6620)  

Security 

• Enhanced SAML SSO authentication provides additional hardening for authenticated sessions, 
any customers using SAML authentication should upgrade to this 5.2.0 release.(13900) 

• Enhanced XF's native authentication providing additional protections for the data store. Any 
customers that use internal authentication will need to log on to Excel when a user launches an 
xlsx file from within our Silverlight or Windows client. (11243). 
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Fixed 
• (12421) The User Defined Members as Attribute will allow the reference to a Text property to 

vary-by-time and correctly reflect totals in hierarchies.  

• (10902) Selecting a Workflow Channel will automatically refresh to display the most current 
content.  

• (10516) The Member Filter Builder will ignore blank spaces when creating a Member Filter 
definition.  Additional member selections will be comma delimited.   

• (10945) Quick View Primary Style "Comma [0]" Causing Rebuild of Quick View to Remove First 
Letter of Member Name in Filter 

• (10286) Dimension Library incorrectly displayed the Entity Relationship settings on Percent 
Ownership and Percent Consolidate prior to selecting Save. 

• (12960) Cube Views designed with Tree expansions having large Entity dimensions will not be 
paged.  This corrects sibling members not displaying because of Cube View Paging. 

• (12921) Application extract files size has now been increased to 2.14 gigabytes to handle large 
dimensions. 

• (13307) Rich Text XFDoc Cube Views are corrected to display the correct formatting when 
multiple Cube Views are included in the same document.  

• (9792) Excel Add-In Formula builder wizard will now display the content for cell-referenced 
dimensions. 

• (9864) When loading Dashboard Maintenance Units artifacts such as Parameters, strings and 
Components as an *.xml file, if items exist in other Dashboard Maintenance Units the load will 
be stopped with an error message.  

• (9957) SQL Table Editor source database columns can now be defined with or without spaces in 
the label. 

• (10729) SQL Table Editor dashboard refresh action will now be executed when only one 
database record exists. 

• (10962) Dashboard Buttons will retain the underscore character when the Text display is 
sourced from a Parameter containing an underscore. 

• (11309) The Task Progress window will now display the active task and the percent complete. 

• (11719,11885) The OneStreamWeb/OneStreamMvc Web Configuration files will now default the 
maxAllowedContentLength property to allow file uploads to the maximum of 30 megabytes. 

• (11840) Select Member type User Defined dimension Dashboard buttons can be used with or 
without description fields. 

• (12063) Suppression assigned on Cube View rows was incorrectly being applied to subsequent 
non-suppressed rows. 

• (12184) Cube View Conditional Formatting will now correctly display when the Cube View is 
presented as a Dashboard Report. 

 

Known Issues 
• Non-Administrator Application Pool User Returns Errors for PerfLib and PerfNet When Recyling 

IIS and also Background Intelligent Transfer Service When Using "Recycle App Pool" (14336) 

• BI Designer/Viewer Regression - not right-sizing or rendering Pie Charts and labels. When 
creating a Pie Chart or Gauge in the BI Designer tab of the BI Viewer component, a Pie or Gauge 
dashboard item will not render properly if the size is too small. Users should be sure to size 
these Dashboard items in their respective window as a workaround. (13456) 
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• Report Preview Error in Cube View Sharing Rows/Columns with same Name in Shared Cube 
Views. (2651) 

• When opening a Workbook that contains OneStream Formulas/Cube Views/Quick Views directly 
from the file system before opening a blank Excel workbook and logging into the OneStream 
Excel Add-In, the user may receive a “Cannot run the macro ‘XFInternalSetConnectionInfo’ error. 
As a workaround, the user can open Excel, log in and then open the XLSX file, or they can launch 
the file from within OneStream if it is in the File Repository. (5024) 

• To have SSL security configured between the OneStream Application and Web Servers, 
Application Pools must use a local administrator account rather than a domain account for On-
Prem. (4603) 

• Excel Extensible Documents may not retain the margin and print area formatting when assigned 
to a OneStream Book of reports. (9052) 

• Viewing Dashboards in the Silverlight Web Browser which are designed to contain more than six 
levels of nested Dashboards may not render as expected.  Users encountering this issue should 
use the OneStream Windows Application interface as a solution. (10136), (10102) 

• Users editing dimension hierarchies through the Silverlight-based web interface may experience 
an intermittent issue where the Dimension Library page become unavailable.  Use of the 
OneStream Windows Application is the recommended solution for application management to 
avoid this situation. (10274) 

• (13975) The import of application extract files currently has a maximum file size of 1 gigabyte.  
File sizes greater must have the extracts redefined to yield a smaller file size. 

• Large Data Pivot Grid does not support records with Measures stored as “Null”. (14200) 

• Large Data Pivot Grid displays an error when Pre-Filter is used on dimensions set in Filter Area. 
(14118) 

Contacting Support 
OneStream Support can be contacted at any time by first registering at our support site at 
http://support.onestreamsoftware.com and then emailing support@onestreamsoftware.com.  To gain 
access to the XF MarketPlace, email OneStream Support. 

 

http://support.onestreamsoftware.com/
mailto:support@onestreamsoftware.com
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OneStream XF MarketPlace Updates 

The following updates were made to XF MarketPlace solutions since the release of OneStream XF 5.1.1. 

Account Reconciliations 
Performance improvements, minor defect resolution, and user improvement features.  

Administrator Solution Tools Overview 
Administrator Solution Tools provides a single dashboard to access multiple solutions, each enabling 
OneStream XF administrators to perform their role effectively and efficiently. This new solution includes 
Home Page Manager, Log Cleaner and Member Formula Builder functionality. 

End User Training – Cube Views 
Updates to the materials to include additional Cube View features such as standard and conditional 
formatting, Excel formats, reverse member expansion, and substitution variable.  

End User Training – Spreadsheet Analysis 
Updates to the materials to include the OneStream XF Spreadsheet feature.  

Diagnostic 123 
User improvement features and defect resolutions.  

Help Desk 
Incremental improvements including Email notification when Assigned Owner is changed, a new ticket 
status of Waiting for Information, and requiring Ticket Information to be completed for ticket creation.  

MarketPlace Solution Tools 
Availability of the Solution Analysis Tool. 

Provision Request Manager 
OneStream XF 5.0.4 and PV5.1.0 compatibility and a change to the solution download package folder 
structure and solution install process. 

Security Audit Report 
Incremental improvements including the creation of a new User Report, User List – Grid View, which 
expands User List report with the addition of new columns and allows for filtering by column. Changes 
were also made to the User Interface to match the Standard Application Report.  

Task Manager  
Minor defect resolution and incremental improvements including an alternative Simplified view 
Scorecard that can be optionally displayed via a User Preference setting. 

User Management Console 
Compatibility with OneStream XF 5.0.0 and defect resolutions.   
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OneStream XF 5.2.0 Upgrade Guide 

This document provides an overview of OneStream XF’s upgrade process when moving from an earlier 
OneStream XF release to 5.2.0. The anticipated audience for the upgrade process is Information 
Technology professionals responsible for installing, maintaining and supporting OneStream XF.    

Review the following OneStream XF 5.2.0 requirements prior to scheduling an upgrade and any related 
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.  

1.) If upgrading from OneStream XF version 4.1.x or earlier, OneStream updated to .NET 4.7 to stay 
current on the latest version of the .NET Framework, which is required for Microsoft’s security 
standards and for advanced features.  Please note, Microsoft provides the .NET Framework 4.7 
optional update through standard Microsoft Windows Updates.   

2.) The most recent database schema update was 5.1.0. There is a need for a database schema update 
if upgrading from 4.2.x or 4.3.x or 5.x to version 5.2.0. If upgrading from a version 4.2.0 or earlier, 
Database Schema updates must be implemented as part of the upgrade on every Application and 
Framework database. Full Database Backups are recommended. 

3.) The 5.2.0 version of the OneStream Studio and OneStream Excel Add-in are not backward 
compatible with versions to 5.x and must be updated. These either need to be uninstalled and 
reinstalled or use the Client Updater. See OneStream XF Installation and Configuration Guide for 
details under the section “Upgrade or Downgrade via OneStream.”  

4.) If upgrading from a version 4.2.0 or earlier, it is required that all OneStream Applications complete 
the Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade 
process.  

Scheduling the Upgrade 
It is recommended that this upgrade be performed by the OneStream Software Technical Support Team.  
Contact OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com. 

Pre-Installation Upgrade Checklist 
The checklist below details the items that should be completed prior to beginning the upgrade 
operation: 

Step 1: Perform a full backup of all OneStream databases. 

Step 2: App Pool Service Account must use an Administrator ID or be added to the Performance 
Monitors User Group, IIS_IUSRS Group and Performance Log Users Group.  

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace 

1.) Login to the OneStream XF MarketPlace and select Software Download in order to access the latest 
version of OneStream XF. 

2.) Download the Full Package or Server Software to acquire the appropriate setup files for the server 
installation. 

Step 4: Verify the Location of the OneStream XF Configuration Files 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

mailto:support@onestreamsoftware.com
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2.) Right-click on the utility and select Run as Administrator 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb, on web servers, and choose the 
web.config file 

4.) The web.config will open and display the path to the corresponding configuration files: 
XFAppServerConfig.xml and XFWebServerConfig.xml 

5.) Take a copy of the config file 
6.) Copy and paste the configuration file path in a place that is easily accessible as this will need to be 

re-entered following the upgrade process 
7.) Close the file, and select No when prompted to save  
8.) Close the OneStream Server Configuration Utility 

Step 5: Verify the OneStream Service Account in Internet Information Services Manager (IIS) 

1.) Service Account must be an Admin ID or in the IIS_IUSRS Group, Performance Log User and 
Performance Monitor Users groups. 
This ID is necessary to use Queuing and CPU Monitoring. 

2.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

3.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and 
OneStreamWebAppPool are displayed in the Identity column.  Note this windows account and its 
password as this will need to be re-entered in IIS following the upgrade process.  

Step 6: Verify OneStream Application Server with OneStream Database Configuration Utility Installed 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server has the OneStream Database Configuration Utility installed. This will need to be 
re-installed on the application server during the upgrade operation. 

Step 7: Verify OneStream Application Server with OneStream Studio Installed (if applicable) 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server(s) has OneStream Studio installed.  This will need to be re-installed on the 
application server during the upgrade operation. 

 

Upgrading System Components 
The following section describes the process used to upgrade the complete OneStream XF system. 

Step 1: Stop OneStream Application Pools Prior to Uninstall  

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager) 

2.) Expand the server in the left pane and select Application Pools 
This will display a list of application pools in the right pane. 

3.) Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and 
selecting Stop (Note: Close any open OneStream Configuration Utilities) 

4.) Repeat these steps for each server in the environment 
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Step 2: Uninstall the OneStream XF Servers Package 
In order to upgrade to a new release, the previous software release must be uninstalled from all servers 
before the new release can be installed on each server in the environment. 

1.) Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the OneStream 
Servers component in the list 

2.) Right-click on the OneStream Servers component and select Uninstall 
3.) If OneStream Studio is also installed, locate the OneStream Studio component in the list, right-click 

and select Uninstall 

Step 3: Re-Install the OneStream XF Servers Package on an Application Server 

This is the primary OneStream XF installation package. This wizard-based package is used to install a 
complete server setup which includes web server, application server, and all utilities.  This can also be 
used to do a custom install which allows the user to pick and choose the appropriate components for 
the server type being built. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Application Server and Server Configuration Utility on the Select Features page and 

click Next 
Note: The Database Configuration Utility may also be chosen if the application server is the server 
where the Database Configuration Utility was installed in the previous version of OneStream XF. 

6.) Click Install to install the software and click Finish when it is complete 

Step 4: Re-Install the OneStream XF Servers Package on a Web Server 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Choose the installation directory where the software was previously installed and click Next 
5.) Choose the Web Server and Server Configuration Utility on the Select Features page and click Next 

NOTE: If Mobile is installed, check the Mobile Web Server Option also 

6.) Click Install to install the software and click Finish when its complete 

Step 5: Re-Install the OneStream XF Studio Package 

1.) Browse to the OneStream Studio package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package 

2.) Click Next at the landing page and accept the License Agreement 
3.) Select the Custom option and click Next 
4.) Select the installation directory where the software was previously installed 

(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next 
5.) Choose all options on the Select Features page and click Next 
6.) Click Install to install the software and click Finish when its complete 

Step 6: Upgrade OneStream XF Framework and Application Databases  
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Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application Databases) 
prior to running the schema update operation. 

1.) On the OneStream application server with the OneStream Database Configuration Utility installed, 
navigate to the utility 
Start > Programs > OneStream Software > OneStream Database Configuration Utility   

2.) Right-click on the utility and choose Run as Administrator 
3.) Right-click on the OneStream Framework Database and choose Upgrade Database Version 

Note: If this is grayed out, an upgrade to the database is not necessary 
4.) Confirm the upgrade of the database 
5.) Repeat this process for the application database(s) as necessary 

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers, and select the 
web.config file 

4.) When the web.config opens, paste the Configuration Files Folder path 
5.) Close the file making sure to save upon closing 
6.) Repeat this process on each server in the environment 

Step 8: Update Application and Web Server Config Files 

1.) Open Application Server Configuration file and Click File > Save 
2.) Close and re-open the Application Server Configuration File 
3.) Scroll to Database Server Connections and select the ellipsis (…) icon 

• Update command Time-outs for OneStream Database Server Connection: 
o Short = 90 *must do 
o Large = 900 (minimum of 900) 

4.) Save and Close Application Server Configuration file 
5.) Open Web Server Configuration file 
6.) Click File > Save 
7.) Close Web Server Configuration file 

Step 9: Update Identity to OneStream Service Account in Internet Information Services Manager (IIS) 
Using OneStream Server Configuration Utility “Configure IIS Tool” 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility) 

2.) Right-click on the utility and select Run as Administrator 
3.) Choose Tools > Configure IIS 
4.) Update the Configure IIS Dialog as follows 

a. Web Site Name: Enter the name of the OneStream IIS Website that will be updated 
i. OneStream App Server Site 

ii. OneStream Web Server Site 
iii. OneStream Mobile Server Site 

b. Check the “Update IIS Default Settings” box 
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c. Set the radio button for updating the appropriate website 
i. Set the radio button to “Use XF Web Server Settings” when updating IIS for the 

OneStream Mobile Web Server Site 
ii. Set the radio button to “Use XF Web Server Settings” when updating IIS for the 

OneStream Web Server Site 
iii. Set the radio button to “Use XF App Server Settings” when updating IIS for the 

OneStream App Server Site 
d. User Account Type: Select Custom Account  
e. Enter the User Name and Password of the OneStream Service Account 

5.) Click the “Update IIS Settings” button after setting the appropriate fields and confirm the dialog with 
“OK”  
6.) Repeat this to set the appropriate IIS Settings for the application pools in IIS 
7.) Click the Reset IIS button to perform an IISRESET on the server for the changes to take effect. 
 

Step 10: Test OneStream Environment Login 

1.) Navigate to the OneStream Web URL: 
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx 

2.) Verify the ability to login to OneStream XF 
3.) Select System Administration from the application drop down list and click Connect 
4.) Navigate to System tab, Tools > Environment 

This will display a list of all application servers and their server status 
5.) Verify each server’s status shows as active and shows in green 

Step 11: Application Verification 

6.) Compile ALL Business Rules 

• Right click grid and Export any errors to an Excel file format for analysis 

• Apply updates to Business Rules as need 
7.)  Import new Standard Reports after downloading from Store on XF MarketPlace  

 


