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OneStream XF Version 5.3.0 
Release Notes 

Updated: December 13, 2019 

This release of OneStream XF contains a variety of features developed to enhance the design 
capabilities, performance and ease of use of applications.   Designers, system administrators and users 
will benefit from the enhancements across their application.  The “Retain Formulas” feature, in 
Spreadsheet and Excel, will offer end-users greater flexibility in managing their data submissions.  
Designers and system administrators are provided new tools and properties to design, create and 
manage applications with the new “Copy Dashboard” functions, as well as Dashboard Component and 
Cube View enhancements.  Modeling with BI Blend now includes new Aggregation Controls to more 
efficiently define the results table along with new Connector BRAPI’s to source data from Cube data and 
source systems. 
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Important Notes 

Prerequisites 
See the OneStream XF 5.3.0 Upgrade Guide section for important notices and details regarding planning 
your upgrade.  

Compatibility and Important Notices 
See the OneStream XF 5.3.0 Upgrade Guide section later in this document for information on 
compatibility of the OneStream Studio and OneStream Excel Add-in versions.  

OneStream XF users are encouraged to adopt the OneStream Windows App. The OneStream XF web 
interface has been developed utilizing Microsoft’s Silverlight web browser plug-in.  Microsoft officially 
announced in 2012 that development of Silverlight will be discontinued with support scheduled to end 
in October 2021.  The OneStream Windows Application is the replacement for the Silverlight-based 
browser interface.  Customers should note that certain new features may only be available in the 
OneStream Windows App due to its technology advantages.  In addition, users can access OneStream XF 
through the HTML5-based OneStream Mobile and OneStream Excel Add-in.  OneStream will not support 
the Silverlight-based web browser interface beyond 2021.  

OneStream XF version 5.3 will be the last version to support the Windows 7 operating system.  Windows 
7 shall no longer be supported as a client operating system as of January 14, 2020, in line with 
Microsoft’s mainstream support policy.   
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OneStream XF 

New Features 

BI Blend  

Development of BI Blend in 5.3 has been focused on providing additional capabilities to more 
precisely define the data records in the results table.  The new Aggregation Controls, such as the 
“non-inclusive”, allow more granular filtering of the aggregation results.  Additionally, a new set of 
Fast Data Extract, or “FDX Connector” BRAPI’s are included to allow Cube data and source system 
Data Sources to be defined and optimized for BI Blend.   

Performance has been enhanced with the ability to partition within the Blend Unit.   This is done by 
managing data records using the Data Source “Source ID”.  Additional performance gains are found 
with new settings to manage the database with Shrink After Finalize and through greater integrity 
with enhancements to the Learning Mode process. 

The application table StageBlendInfo, now captures additional metadata properties for options to 
report on BI Blend processes. 

Please review the details of the BI Blend features in the BI Blend Design and Reference Guide found 
in the full documentation package. 

• BI Blend Content Type “TimeWFViewAV” now supports the Transformation Rules property of 
Flip Sign. (14412) 

• A new Aggregation Type has been created for use with the Create Star Schema method.  The 
Aggregation Type “SSOnly” will create the entire dimension from the Root member in the Star 
Schema table.  The dimension members are not created as stored aggregation records. (14757) 

• Aggregations can be defined as “non-inclusive” to allow dimension “Top” member to be utilized 
without generating aggregation data records. (14886) 

• FDX, Fast Data Extract, BRAPI’s allow a variety of options for connecting to DataSources for BI 
Blend.  A key differentiator between the FDX BRAPI’s and other collection methods is support of 
parallel processing, in-memory processing and management of the Time dimension. (14365) 

Business Rules 

• A new BRAPI has been added to “Members”: ReadParentRelationshipsNoCache enhances the 
ability to manage metadata through business rules.  This new function is used to validate if a 
member has a relationship with a parent or is an “orphan” member.  (15056) 

“Retain Formulas in Cube View Content” in Excel and XF Spreadsheet 

Retain Formulas in Cube View Content is a new Cube View setting that has been added to the 
Cube View Connection dialogue box within Excel and Spreadsheet. This new feature allows users 
to form Cube View grids of data in Excel (using the Cube Views menu function), that can then be 
linked to other Excel models for easy submission into OneStream. This feature allows formulas 
(to writeable cells) in Excel (or Spreadsheet) for an attached Cube View to be retained on 
submission and retrieval instead of being replaced with the value of the represented formula. 
(14814,12115).  

Presentation 
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Copy (and Paste) Dashboards, Components, Adapters, Parameters, Files and 
Strings 

• Copy and paste Dashboards, Components, Adapters, Parameters, Files, and Strings within or 
across Dashboard Maintenance Units.  

Multiple items can be selected all at once using Shift+click or Ctrl+click. The ability to copy and 
paste using right-click or toolbar menu buttons and Copy and Paste (new). Items can be copied 
and pasted multiple times and each time the item is pasted, a suffix of _Copy will be added. For 
every additional instance of the Dashboard item that is pasted a suffix of _Copy (instance#) will 
be added. Excluded from Copy: Maintenance Units, Dashboard Groups, Dashboard Profiles, 
Profile Members. (13953) 

SQL Table Editor 

• The SQL Table Editor has new properties to allow designers to customize the display of the Title 
bar and to define the activation/deactivation of the toolbar buttons.  Designers are now able to 
define the complete Component control to manage the ability to “save and revert” the state.  
(11359) 

Grid Viewer 

• The Grid Viewer now supports “user-preference” control properties with the new Columns 
Settings button.  When activated as a property, a user can re-order and manage the visibility of 
columns.  A new “Save State” property will retain the Column Settings selections as a 
preference. (12547) 

Dashboards 

• Dashboard properties now include the ability to activate or deactivate the panel “x” close 
button.  The Display Format property includes the new setting of EnableSystemClose.  (14193) 

• Removed the hover functionality with the Hamburger icons and make it open and close with 
clicking only. (10738) 

• Removed the light-blue border around the BI Viewer. (14858) 

Large Data Pivot Grid 

• A new property, Save State, has been added to the Large Data Pivot Grid to activate the Save 
State toolbar button.  The default setting will be “False”.  (14695) 

Cube Views 

• Cube View performance has been enhanced with a new Column Data Property “Used To 
Determine Row Suppression”.  This new setting allows a designer to tailor the columns used to 
evaluate row suppression intersections.  (14356) 

Work Flow 

• Data Quality Cube View Profiles have been enhanced to support the user-toolbar button to 
customize Row Suppression settings. (11699) 

Table Views 

• The Table Selection window is now filtered by the Business Rule Type, displaying only 
Spreadsheet Type Business Rules for simplified navigation. (14565) 
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Fixed 
• (14916) Metadata Property, “Display Member Group”, was not properly changed for the 

assigned Security Group. 

• (14335) OneStreamMgmtAppPool IIS default recycling has been changed to 0 from 30 minutes.  
This change will no longer override the default 120-minute Idle Time Out settings and minimize 
application pool recycling. 

• (6424,14410) When data is being written to a Data Unit through Business Rules, a Force 
Consolidate is no longer required across hierarchies. Workflow Intercompany Matching reports 
do not require Force Translate to view Reporting or Partner Currency translations. 

• (12441) Application Cube View Logo with a low pixel density will correctly display in Cube View 
Headers and Dashboards. 

• (12360) User Defined Attribute properties are enabled for viewing and sorted in the Dimension 
Grid Viewer. 

• (11519, 10698) Cube View Conditional formatting now supports additional properties when 
using the MemberName condition. 

• (11457) OneStream XF Studio XF Sub Reports can manage controlling the inclusion of the Report 
Header and Header Bar using the Cube View Report Properties of ReportIncludeHeader and 
ReportIncludeColumnHeaderLine.  These Cube View formatting properties are used in place of 
the Studio XFSubReport properties. 

• (11308) Cube View Mask Transformation Rules will launch the Conditional Expression Editor 
when using the Logical Operator. 

• (11247) When running an Excel Export Item in an Excel Book from within a Dashboard, the Book 
will launch as a Microsoft Excel workbook. 

• (10752) The Workflow Process Step activity details will be displayed in the Task Activity log 
within the Description field. 

• (10515) Workflow Calculation Definitions using “User Cell Input Entity” no longer display error 
messaging if an Entity in the definition has been deleted. 

• (10386) Forms with Cube Views, designed using Parameter-based formatting, will retain all 
formatting when Forms are Reverted. 

• (10285) Workflow Import property description has been corrected for “Can Load Unrelated 
Entities”. 

• (14203, 14197) The Large Data Pivot Grid fields support database column names containing 
blank spaces. 

• (14171) Enabling or disabling Large Data Pivot Grid Row Totals will retain the positioning of the 
grid “grand totals” at the bottom of the display. 

• (14200) Database “Null” member values in data records are now able to be filtered in the Large 
Data Pivot Grid. 

• (14118) Large Data Pivot Grid filters, in the Hidden Area or Filter Area, will support PreFilter 
conditions without displaying a reference error. 

Known Issues 
• Non-Administrator Application Pool User Returns Errors for PerfLib and PerfNet When Recyling 

IIS and also Background Intelligent Transfer Service When Using "Recycle App Pool" (14336) 

• The Report Preview Error in Cube View Sharing Rows/Columns with the same Name in Shared 
Cube Views. (2651) 

• When opening a Workbook that contains OneStream Formulas/Cube Views/Quick Views directly 
from the file system before opening a blank Excel workbook and logging into the OneStream 



   
 

OneStream XF Version 5.3.0 Release Notes Page 5 of 12 
 

Excel Add-In, the user may receive a “Cannot run the macro ‘XFInternalSetConnectionInfo’ error. 
As a workaround, the user can open Excel, log in and then open the XLSX file, or they can launch 
the file from within OneStream if it is in the File Repository. (5024) 

• To have SSL security configured between the OneStream Application and Web Servers, 
Application Pools must use a local administrator account rather than a domain account for On-
Prem. (4603) 

• Excel Extensible Documents may not retain the margin and print area formatting when assigned 
to a OneStream Book of reports. (9052) 

• Mapping to Data to UD Entity Default Is Not Aggregating With Row Mapping to Same UD 
Explicitly When Loading to Cube. (9549) 

• Viewing Dashboards in the Silverlight Web Browser, which are designed to contain more than six 
levels of nested Dashboards, may not render as expected.  Users encountering this issue should 
use the OneStream Windows Application interface as a solution. (10136), (10102) 

• Users editing dimension hierarchies through the Silverlight-based web interface may experience 
an intermittent issue where the Dimension Library page becomes unavailable.  Use of the 
OneStream Windows Application is the recommended solution for application management to 
avoid this situation. (10274) 

• (13975) The import of application extract files currently has a maximum file size of 1 gigabyte.  
File sizes greater must have the extracts redefined to yield a smaller file size. 

• Within Business Rule scripting, Member Object Properties are now set as “read-only” and must 
be written during member construction. (14404) 

• With the Dashboard ‘undo’ button, “Cancel all changes since last save”, users will have to exit 
the screen to undo changes for the Dashboard Item. (15854) 

• The Reset Large Data Pivot Grid (LDPG) to Component Settings (Revert Layout button) should be 
grayed out before settings are changed and once it has been used and the settings are restored. 
Once changes are made to the LDPG the user can refresh the screen to enable the Revert Layout 
button.(13876) 

• The Large Data Pivot Grid will not display a label for filter members which are “Null” or “Empty 
String” fields in records.  The first checkbox represents “Null” and the second checkbox 
represents “Empty String”. (15362) 

• The Dashboard ‘undo’ button - “Cancel all changes since last save” does not work for Dashboard 
Items. (15854) 

Contacting Support 
OneStream Support can be contacted at any time by first registering at our support site, 
http://support.onestreamsoftware.com and then emailing support@onestreamsoftware.com.  To gain 
access to the XF MarketPlace, email OneStream Support. 

 

http://support.onestreamsoftware.com/
mailto:support@onestreamsoftware.com
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OneStream XF 5.3.0 Upgrade Guide 

This document provides an overview of OneStream XF’s upgrade process when moving from an earlier 
OneStream XF release to 5.3.0. The anticipated audience for the upgrade process is Information 
Technology professionals responsible for installing, maintaining and supporting OneStream XF.    

Review the following OneStream XF 5.3.0 requirements prior to scheduling an upgrade and any related 
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.  

1.) If upgrading from OneStream XF version 4.1.x or earlier, it is required to update OneStream to .NET 
4.7  for Microsoft’s security standards and for advanced features to stay current on the latest 
version of the .NET Framework.  Please note, Microsoft provides the .NET Framework 4.7 optional 
update through standard Microsoft Windows Updates.   

2.) The most recent database schema update was 5.2.0. There is a need for a database schema update 
if upgrading from 4.2.x, 4.3.x or 5.x to version 5.3.0. If upgrading from version 4.2.0 or earlier, 
Database Schema updates must be implemented as part of the upgrade on every Application and 
Framework database. Full Database Backups are recommended. 

3.) The 5.3.0 version of the OneStream Studio and OneStream Excel Add-in are not backward 
compatible with versions up to 5.x and must be updated. These either need to be uninstalled and 
reinstalled or use the Client Updater. See OneStream XF Installation and Configuration Guide for 
details under the section “Upgrade or Downgrade via OneStream.”  

4.) If upgrading from a version 4.2.0 or earlier, it is required that all OneStream Applications complete 
the Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade.  

Scheduling the Upgrade 
It is recommended that this upgrade be performed by the OneStream Software Technical Support Team.  
Contact OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com. 

Pre-Installation Upgrade Checklist 
The checklist below details the items that should be completed prior to beginning the upgrade 
operation: 

Step 1: Perform a Full Backup of All OneStream Databases 

Step 2: App Pool Service Account must use an Administrator ID or be added to the Performance 
Monitors User Group, IIS_IUSRS Group and Performance Log Users Group.  

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace 

1.) Login to the OneStream XF MarketPlace and select Software Download to access the latest version 
of OneStream XF. 

2.) Download the Full Package or Server Software to acquire the appropriate setup files for the server 
installation. 

Step 4: Verify the Location of the OneStream XF Configuration Files 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility). 

2.) Right-click on the utility and select Run as Administrator. 

mailto:support@onestreamsoftware.com
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3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 
Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb, on web servers, and choose the 
web.config file. 

4.) The web.config will open and display the path to the corresponding configuration files: 
XFAppServerConfig.xml and XFWebServerConfig.xml. 

5.) Copy the config file. 
6.) Copy and paste the configuration file path in a place that is easily accessible as this will need to be 

re-entered following the upgrade process. 
7.) Close the file and select No when prompted to save.  
8.) Close the OneStream Server Configuration Utility. 

Step 5: Verify the OneStream Service Account in Internet Information Services Manager (IIS) 

1.) The Service Account must be an Admin ID or in the IIS_IUSRS Group, Performance Log User and 
Performance Monitor Users groups. 
This ID is necessary to use for Queuing and CPU Monitoring. 

2.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager). 

3.) Expand the server in the left pane and select Application Pools. 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and 
OneStreamWebAppPool are displayed in the Identity column.  Note this windows account and its 
password as this will need to be re-entered in IIS following the upgrade process.  

Step 6: Verify the OneStream Application Server with the OneStream Database Configuration Utility 
are Installed 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server has the OneStream Database Configuration Utility installed. This will need to be 
re-installed on the application server during the upgrade operation. 

Step 7: Verify the OneStream Application Server with OneStream Studio is Installed (if applicable) 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server(s) has OneStream Studio installed.  This will need to be re-installed on the 
application server during the upgrade operation. 

Pre-Installation Member Object Rules Evaluation 

OneStream XF Version 5.2 introduced a coding change making Member Objects Read-Only as part of 
regular, on-going code enhancements.  This change may cause issues with some existing applications 
where business rules are used to create or edit metadata.  

This issue can be identified by: 

• Business Rules which create, or update metadata can be analyzed for problematic syntax. 

• After 5.2, compiling all Business Rules should display errors related to read-only objects. 

Member Object Application Errors 

This rules error can be identified after upgrading through a standard Business Rules compile.  The 
Member Objects will cause an error to display. 
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The error will also display when the rules are executed through the application. 

 

Member Object Identify Problematic Rules 

Early rules may have been designed in a manner where the Member object was written-to directly.  This 
syntax is no longer valid and is the cause of the compile and application errors. 

 

The Objects related to Member can be viewed using the “IntelliSense” feature, and each will be 
identified with their “read-only” status. 
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Member Object Rules Solution  

The new design of the rule must define the objects while the member is constructed in the rules using 
the Member constructor to define the Member variable.  The resulting variable is then used to update 
the metadata or metadata properties. 

This function contains multiple variations depending upon the use requirements.   

The example below is the common syntax requirement to create a new member, such as a User Defined 
member. 

Member( memberPk , Name as String, Description as String, dimID as Integer ) 

 

Member Object Updates to Existing Members 

There may also be instances where business rules are used to modify existing metadata member 
properties.   Since the Objects are now read-only, updates to existing member objects, such as 
Descriptions, must be performed using the Member constructor.  This will require the use of an 
alternate syntax on the Member function. 

The existing member’s properties must be passed into the function, updating only the desired property.  
For example, all the existing properties of the current member can be used in the New Member 
constructor, modifying only the “Description” property to perform an update to the existing member. 

 

 

Upgrading System Components 
The following section describes the process to upgrade the complete OneStream XF system. 

Step 1: Stop OneStream Application Pools Prior to Uninstall  

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager). 

2.) Expand the server in the left pane and select Application Pools. 
This will display a list of application pools in the right pane. 

3.) Close any open OneStream Configuration Utilities. 
4.) Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and 

selecting Stop.  
5.) Repeat these steps for each server in the environment. 

Step 2: Uninstall the OneStream XF Servers Package 
To upgrade to a new release, the previous software release must be uninstalled from all servers before 
the new release can be installed on each server in the environment. 
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1.) Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the OneStream 
Servers component in the list. 

2.) Right-click on the OneStream Servers component and select Uninstall. 
3.) If the OneStream Studio is also installed, locate the OneStream Studio component in the list, right-

click and select Uninstall. 

Step 3: Re-Install the OneStream XF Servers Package on an Application Server 

This is the primary OneStream XF installation package. This wizard-based package is used to install a 
complete server setup, which includes the web server, application server, and all utilities.  This can also 
be used for a custom install, which allows the user to pick and choose the appropriate components for 
the server type being built. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package. 

2.) Click Next at the landing page and accept the License Agreement. 
3.) Select the Custom option and click Next. 
4.) Choose the installation directory where the software was previously installed and click Next. 
5.) Choose the Application Server and Server Configuration Utility on the Select Features page and 

click Next. 
Note: The Database Configuration Utility may also be chosen if the application server is the server 
where the Database Configuration Utility was installed in the previous version of OneStream XF. 

6.) Click Install to install the software and click Finish when it is complete. 

Step 4: Re-Install the OneStream XF Servers Package on a Web Server 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package. 

2.) Click Next at the landing page and accept the License Agreement. 
3.) Select the Custom option and click Next. 
4.) Choose the installation directory where the software was previously installed and click Next. 
5.) Choose the Web Server and Server Configuration Utility on the Select Features page and click Next. 

NOTE: If Mobile is installed, check the Mobile Web Server Option also. 

6.) Click Install to install the software and click Finish to complete. 

Step 5: Re-Install the OneStream XF Studio Package 

1.) Browse to the OneStream Studio package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package. 

2.) Click Next at the landing page and accept the License Agreement. 
3.) Select the Custom option and click Next. 
4.) Select the installation directory where the software was previously installed 

(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next. 
5.) Choose all options on the Select Features page and click Next. 
6.) Click Install to install the software and click Finish to complete. 

Step 6: Upgrade OneStream XF Framework and Application Databases  

Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application Databases) 
prior to running the schema update operation. 
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1.) On the OneStream application server with the OneStream Database Configuration Utility installed, 
navigate to the utility 
Start > Programs > OneStream Software > OneStream Database Configuration Utility. 

2.) Right-click on the utility and choose Run as Administrator. 
3.) Right-click on the OneStream Framework Database and choose Upgrade Database Version. 

Note: If this is grayed out, an upgrade to the database is not necessary. 
4.) Confirm the upgrade of the database. 
5.) Repeat this process for the application database(s) as necessary. 

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility). 

2.) Right-click on the utility and select Run as Administrator. 
3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers and select the 
web.config file. 

4.) When the web.config opens, paste the Configuration Files Folder path. 
5.) Close the file and Save. 
6.) Repeat this process on each server in the environment. 

Step 8: Update Application and Web Server Config Files 

1.) Open the Application Server Configuration file and Click File > Save. 
2.) Close and re-open the Application Server Configuration File. 
3.) Scroll to Database Server Connections and select the ellipsis (…) icon. 

• Update the command Time-outs for the OneStream Database Server Connection: 
o Short = 90 *must do 
o Large = 900 (minimum of 900) 

4.) Save and Close the Application Server Configuration file. 
5.) Open the Web Server Configuration file. 
6.) Click File > Save. 
7.) Close the Web Server Configuration file. 

Step 9: Update the Identity to the OneStream Service Account in Internet Information Services 
Manager (IIS) Using OneStream Server Configuration Utility “Configure IIS Tool” 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility). 

2.) Right-click on the utility and select Run as Administrator. 
3.) Choose Tools > Configure IIS. 
4.) Update the Configure IIS Dialog as follows: 

a. Web Site Name: Enter the name of the OneStream IIS Website to update. 
i. OneStream App Server Site 

ii. OneStream Web Server Site 
iii. OneStream Mobile Server Site 

b. Check the “Update IIS Default Settings” box. 
c. Set the radio button for updating the appropriate website. 

i. Set the radio button to “Use XF Web Server Settings” when updating IIS for the 
OneStream Mobile Web Server Site. 
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ii. Set the radio button to “Use XF Web Server Settings” when updating IIS for the 
OneStream Web Server Site. 

iii. Set the radio button to “Use XF App Server Settings” when updating IIS for the 
OneStream App Server Site. 

d. User Account Type: Select Custom Account. 
e. Enter the User Name and Password of the OneStream Service Account. 

5.) Click the Update IIS Settings button after setting the appropriate fields and click OK. 
6.) Repeat this to set the appropriate IIS Settings for the application pools in IIS. 
7.) Click the Reset IIS button to perform an IISRESET on the server for the changes to take effect. 
 

Step 10: Test the OneStream Environment Login 

1.) Navigate to the OneStream Web URL: 
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx. 

2.) Verify the ability to login to OneStream XF. 
3.) Select System Administration from the application drop-down list and click Connect. 
4.) Navigate to the System tab, Tools > Environment. 

This will display a list of all application servers and their server status. 
5.) Verify each server’s status shows as active and green. 

Step 11: Application Verification 

1.) Compile ALL Business Rules. 

• Right-click the grid and Export any errors for analysis using an Excel file format. 

• Apply updates to Business Rules as need. 
2.)  Import new Standard Reports after downloading from the Store on XF MarketPlace. 

 


